Please help. Not receiving information from contact form.

15 0 1

Recently I noticed I wasn't receiving any emails from my Contact US form.  The form is on my site but when I tried to send a test email, I received no notification.  I've tried several times to send test emails but I received nothing.  Can anyone help with this please?


Shopify Partner
576 124 195

Please share your Contact US page URL?




Shopify Expert | Skype: tejas.nadpara
- Like and Mark as an Accepted Solution if reply helpful
- Feel free to contact me on regarding any help
3 0 1



I was able to fix my issue and I sent a test e-mail to myself to verify. Go to the ADMIN page, settings at the bottom of the page, click general. Make sure the e-mail sections reflect where you want the e-mails to be sent to. I used the same e-mail in both to make it simple for myself. You will have to test this to see if it works. I placed an example below:





Store details

Shopify and your customers will use this information to contact you.


Store name YourStore Name


Store contact email []

We'll use this address if we need to contact you about your store.


Customer email []

Your customers will see this address if you email them


Hope this helps!!




8 0 0

Hey guys! I finally figured it out.


One of my forms was made by a template in Shopify. One was built in Pagefly, a custom one. 


When I select the form section with my cursor, these are the menus that show up on the right-hand size. Left pic is the custom form. Right is the one edited out of a template. I still can't get the left one to send to my email but when I selected "Contact" as the form type in the right pic, it finally started sending me emails. I checked my Customer list in Shopify, and sure enough, the forms were being sent straight to my Customer list before. 


Next, I'm going to try to see what happens if I drag the "Contact Form" building block into my page on the custom form page, then edit from there to see if that makes it link to my email. I built the left one from Form Fields only, so maybe that's why it doesn't work. 


Screen Shot 2020-02-04 at 10.48.43 PM.pngScreen Shot 2020-02-04 at 10.48.58 PM.png