Social sharing image not working

Solved
21MillionCo
New Member
2 0 1

Hi Julie, thanks for getting back so quickly. I was using the "Debut" theme, and did not realize that the "theme settings" overrides "preferences." I changed the photo there, and it worked! Thanks again

BkSaberSounds
New Member
2 0 2

I also am using the Debut theme, and have uploaded a new 'social sharing image' under Online Store > Preferences > Social Sharing Image, and it doesn't work. Every post/link I share on any social media shows my default brand site logo only. Ive also tried the FB debugger to refresh the data catch...but it doesnt change. It just wants to keep pulling my site logo for some reason.

 

EDIT: nevermind. Its working now. Just had to wait about 24 hours to see the refresh

Ashlee
New Member
1 0 0

I have done all of these steps and my logo is still not showing when I post my link in Facebook. I have the debut them on Shopify.

0 Likes
Julie
Shopify Staff
Shopify Staff
853 69 207

Hey, @Ashlee!

Thanks for reaching out. 

Just to clarify, did you add your social sharing image in Online store > Themes > Customize > Theme settings > Social media? There, you'll notice a Social sharing image section. This section will always override the social sharing image that you add in Online store > Preferences and this is the case with the Debut theme. 

If you've added your image in your theme settings, then it sounds like Facebook hasn't yet updated the information on their end. If this is the case, then I would recommend waiting a couple of days before attempting to post your store link again.

Another potential reason why you may not be seeing any image when sharing your link could be because you are sharing it on Facebook for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

In other words, there's a good chance that this is expected behaviour and the next time you share your link, you should see your image. 

I hope this clears things up, but let me know if you are still having issues seeing your image. If you can also include the link that you're attempting to share, that would help. 

Looking forward to your update!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

linkilan
New Member
2 0 0

Hey, @Julie!

I have studied this topic and can not fix my problem.
I have a theme "Turbo Portland" and in the settings, I have set a banner for share in social networks, but it is not displayed

 

My website - https://justyokoro.com/

0 Likes
Julie
Shopify Staff
Shopify Staff
853 69 207

Hey, @linkilan!

I appreciate the fact that you've read through this thread for troubleshooting steps.

If you've added your social sharing image in Online store > Preferences and it's not updating, then this sounds like a theme issue. Because you're using a third-party theme, you'll just need to check in with the theme developers for assistance.

It looks like Out of the Sandbox are the developers of your theme and I managed to find some help documentation outlining how social sharing images work with their themes. You can access that right here. Based on what I'm seeing, it looks like the social sharing image in Online store > Preferences should be the one that's used. They do offer some troubleshooting steps if you are having difficulties seeing the image you've uploaded there, however. 

If you're still experiencing the same issue after following their help doc, then you'll need to contact Out of the Sandbox directly. It looks like they have live chat available through their Help Center, so I suggest reaching out there.

I hope this guides you in the right direction!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
Perice
Shopify Partner
9 0 0

Hey all,

if you want to set and customize the social media image for each product, collection or a page, you can use this app:

https://apps.shopify.com/social-media-share-image

Awesome Store Apps for your Shopify store - https://awesomestoreapps.com/
0 Likes
NickiKirk
New Member
2 0 1

Hi Julie! I am having the same issue. I cannot seem to get a logo to appear when sharing to social media. I have checked in the preferences and I have my logo uploaded there. I know that if it is a page like "home" where it does not have an associated image, it will use that image. No image shows. I also followed your instructions to go into themes>customize>social media and uploaded my logo there. Still nothing.... I have chatted with shopify customer care and they told me that it was a facebook issue. But it doesn't show in a text message when a link typically does either. I am lost as what to do here and don't want to share my website until I have it correct which is making me loose more potential sales. Please help! My url is levelsdispensary414.com

0 Likes
Julie
Shopify Staff
Shopify Staff
853 69 207

Hi, @NickiKirk!

Thanks for reaching out and sharing the steps you've already completed. It sounds like you've added your image correctly on Shopify's end, so at this point, it does sound like this issue is stemming from Facebook directly. 

As mentioned above, the Facebook Sharing Debugger is recommended if you still aren't seeing your social sharing image. Did you get a chance to give that a try? Keep in mind that once you do so, it will take Facebook a few days to update the image on their end. 

It's also worth noting that this issue could also be occurring because you are sharing your store link on Facebook for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

That being said, using the Facebook Sharing Debugger usually solves this type of problem, so I suggest that being your next step. 

Let me know how that goes!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

NickiKirk
New Member
2 0 1

Yes I had tried the debugger and I tried to share it to my page privately so that facebook could do its "scan." that seemed to do the trick because my logo is now showing! thank God!