Variant 32x32 images are not loading (were not made ?).

Solved
Tourist
6 1 1

Hi,

 

We use the Portland theme for our shop.

After loading a product with variants, the variant images don't show up in the little squares (see below).

It seems that these images were not made (at least the URL of the images are "not found"). 

 

Any help, suggestions would be greatly appreciated.

 

Peter

 

 

Untitled.jpg

 

 

0 Likes
Shopify Expert
96 17 12

@PLintel - Have you assigned images to each of your variants (can be accomplished by clicking the image placeholder next to the variant on the product page)?  If this has been done, would recommend reaching out to the theme dev's.

0 Likes
Tourist
6 1 1
Yes, the assignments were made, and they work for the main pictures.
0 Likes
Excursionist
13 1 2

There is a bug in the swatch code: background-color has an invalid property value of shown when it should be a hex value. Try adjusting and associating the images again.

 

If all else fails I would contact the maker of your Turbo portland theme-children.

Need shopify help? Drop us an email hi@cnvs.la
Web: www.cnvs.la
0 Likes
Tourist
6 1 1

Ye, I noticed the bug, but I am uncertain if this is a simple / unrelated bug, or a symptom of the problem of the missing images (the files are not made, or so it seems). 

0 Likes

Success.

Tourist
6 1 1

I hacked the code in both swatch files:

...  style="background-image: url({{ variant.featured_image | product_img_url: '600x' | prepend: 'https:' }});  ...

 

0 Likes
Tourist
6 1 1

Untitled.jpg

0 Likes