Changing recipient e-mail adress on the shopify contact form

mvatan
Excursionist
17 0 5

Hi everyone!

I have a question regarding the recipient e-mail adress on the shopify contact form. When someone contacts me through this form on my website I receive the messages on my normal g-mail account. However, I would like to receive them at my business e-mail adress from G-suite. The standard e-mail adress on my shopify account (when I go to Setting>General>Shop details) is my business e-mail adress. Does anyone know how I can receive these messages only on my business e-mail adress and not my personal e-mail adress? Thanks in advance

Greetings Mik

0 Likes
Peter
Shopify Staff
Shopify Staff
2290 243 478

@mvatan 

If you're using the contact page that is provided in the theme, then it should be connected to the email that appears under the "customers email" field in Settings/General. That said, the issue may be connected to either your theme or an app. 

If you're using a contact form app, then the email would need to be updated in the app's admin as it is unlikely that it is pulling from your settings. If you're using a Shopify free theme, then that should update accordingly; however, if you're using a third-party theme then the contact form may not be updating properly. Contacting the theme developer would be the best step in that case. 

Let me know what you find out!

Peter | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
mvatan
Excursionist
17 0 5

So I found out where te problem is I think. This is my G-suite email (picture below) and I have it set as Sender email. So when people contact me on my contact form this is the email adress the emails are send to. However, I don't receive emails when I am test contacting myself. But, I am receiving these test emails on my personal gmail when I change this Sender email to my personal gmail account. I find it strange because my G-suite is verified and also set up as my email hosting provider with the needed mx-records. Do you have any idea why this is happening?

 

mvatan_0-1620425936901.png

 

0 Likes
mvatan
Excursionist
17 0 5

@Peter 

0 Likes