Displaying company names in shopify admin instead of the individuals names

Highlighted
New Member
1 0 0

Just sharing the workaround i used to do this so other B2B sites can use it :)

 

This workaround works for new customers but you will need to go through your current customers and move the names into the correct fields.

It's also a good idea to make a duplicate of your theme to test it on first.

 

Go to online store>themes>actions>edit languages

Click on the customer tab

Hit ctrl f to open up the search box and search name

Use the arrows to go through the whole sheet and where it says "first name" type "Business Name" (or company name etc) into the box  and where it says "last name" type in "Contact Name" into the box

When your finished click save, Go to the checkout & system tab and repeat the step above. Save

Go to admin/settings/checkout and scroll down to form options

If you want the business name to be required click first and last name required, if you want the business name to be optional click require last name only.

Under company name click hidden.

Save.

 

It shows up as Business Name Persons Name 

 

0 Likes
Highlighted
New Member
1 0 0

Thanks for this article because this has been very difficult assistance to get.  This is exactly what I need, but your workaround didn't work for me properly.  Could you advise based on the screen shots attached if I did this correctly?

 

Much appreciated!

0 Likes
Highlighted
Shopify Expert
112 0 23

you need to scroll down more and change the input titles for the section titled "Register" (not the addresses area)


@bblack wrote:

Thanks for this article because this has been very difficult assistance to get.  This is exactly what I need, but your workaround didn't work for me properly.  Could you advise based on the screen shots attached if I did this correctly?

 

Much appreciated!


 

0 Likes