How do I get this google photos embed to work inside product description html

Excursionist
21 2 0

Does anyone know why this html code fails to work inside of a product description...

 

<script src="https://cdn.jsdelivr.net/npm/publicalbum@latest/embed-ui.min.js" async></script>
<div class="pa-carousel-widget" style="width:100%; height:480px; display:none;"
  data-link="https://photos.app.goo.gl/fdDmX5CQnCpPkrm98"
  data-title="Greek Key Ring"
  data-description="13 new photos added to shared album">
  <object data="https://lh3.googleusercontent.com/0qLN_Xu5BgFic25TVrUA-SVNOFM6QW2llhbiLySb7bbWTs-3pYwZi0OLelVcj17qr6rHlUn1Rt4e4f3sT5g3mZjqu2j2ta2waz2LUL9Nu9s7RURpREMbmDiYMb6u6kUMKwWq7i6VNA=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/zSn5SD3eiBIVbFoWnIYJfythDg-YdqvZRwUcKCO_0A5jerwYWUf2QvP0IANQwpUt75xLWiWw6Is8uiIDmwD_y6tXPs7aSaMCfcZSOCVP-PtkZoQbDugp7AszENZyN--c3wBhGO7pjA=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/Y7lISOdW_2v6VKE0F_XebMEUk8NHwxbP9tn1tJ8p7BcJ__EY0MnN0D_lETofiawnbCwkashQfYzsamKHTY3758sPqAUU3pw6m8JvmWQzO9sBLnqRsxUKW-ayN2qoUVYKM1uhm37XPA=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/wP7Hll5v4JkG9Yx91t8A0pGoz1wbJKdWl3M92dhPM9CMdF-_akiYWZVBaLA1SqzFQ8d3sw65mmPwPy-jK8fJ2hqIxiBf1bXjOdHXuV6JK8bAikkyUEF6_1BTZd45OcS05atsGgAiFw=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/OEBngfjcxmFqR_lxkt5beaWwZoHUc2OiEei_Kx7d9ZCR3RjQUZfr2pGMsuvRwKOiVTyxMYmpaQZnL90yRHW2K7DMrcTFVn3XI_vu_x6N9AHmnhFAUW44CyILj_jaWQGd_-Tuc8Lo3Q=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/K6ki8d0DUnqjM81A4DKmxroDgBhLTCvkqjNM9d-FuDh1sIKoc7Tg0DUP2LSLToXXVwd4On9lP5aewYvDFexOWh_w36ViVMPBy4a_BfpISDwYl10mvnlBYwhEGyaCXcS4OvgIQ_SRJw=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/q0eMcSq0N86KVHDd9HRBNFzblmX8Fq77-uhKJnClTd7fEvGozbQztgKn9FMUvKGHwv1DhLz2_0Bi5w7qPQqja9Bi9xfrvJ-Eg2WELOifqdDkMWCuMG9NGKtAwCSlTnWB38tgaHTilQ=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/ocEey_fcol42_CR4XoCDJ6vMPKFW00nb8doIVjJ2GSE-grOjZwL026GWkWT9yGVvpwhy4i4C8Scg6x1NWuJKvzZJF_6vGZBPBgAV0xCPeDqmfOZdd86Wwi4boDoFBJsOfmfL3DOSmQ=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/wJmh9xRpfKnRRgQUGoHPZTwlAo9Nagmuh7LMuYLALNp6ltA3T7OaWrjCTx8mV012MryBZJ-_sBb-aecvfpUeZDELPVHGNnN4-52bwZzSLjcMqBcHqSnEsz_hobP9NimsWxblooxmgQ=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/Dik1vkHNm7XZzV4dZCJI7uBOUzr3cQm9RfiEzOwYBMqy26kVitK2nePTqI0_iL_h1w5rA9TSxFjavjiypS6Wu5dcU5MDyTC8Z1Ecv_M__EDB_4v5xxrqhku4N678PvB_3P9Wbifqcg=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/J9lLLYULC_2hJPY0dKjtdYZabUAw9HbCfV023smdOYCQO3WcevDqPp9xfOgSVbXg0Th62SOdgWszfhJBHWG6u_M9L_IF4vbaQ4iiH0mbOABOrwEXhTD4KuaHYAZcpnRbFeWevu58yw=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/e216NxNB6I8a9qcjhxUXc7INo5hk-m6MHER9ml2zuG37L00DlibNreOJwLg2suJFh1zpNJn0fC8IYRyxkgirxA_vFUjiMjTcG3xW29vZ1v-Mi-m3dNpS_wK_XJi63ncNhkbrp2raBA=w1920-h1080"></object>
  <object data="https://lh3.googleusercontent.com/KbA0w_-CJ9Rtzi4X3NXLCUJCtMGjG8F8eUB15MbIRpByjPhFWguyl3yPwTh3JJYsY5eeCWlMnhYUQ-v1_VN63KDT90A_dvMztRqPliPxepJFhOU6z9Na11OrXVxVyBBTKdzi30vF0A=w1920-h1080"></object>
</div>

What it is meant to be is a google photos gallery embed where each product has a specific gallery of images too look at. I have these codes commented out in the product descriptions so that they are hidden and then call them inside a popup button on the product description pages. This works really well and I am using this already successfully where a sketchfab iframe can be called for the specific product and I can let customers see a 3D veiw of the product they want to buy. Only issue now is that this google photos embed wont work. The embed seems to work inside store code but thats about it

 

Kind Regards

0 Likes
Highlighted
Excursionist
21 2 0

Sorry all just found the issue.... I had a typo somewhere, it works perfectly fine. XD

0 Likes
Highlighted
Excursionist
21 2 0

I take it back this issue isn't solved.... 

 

I have asked another question about this since what I said was incorrect. Below is the link to my new question.

https://community.shopify.com/c/Shopify-Discussion/Why-does-this-code-fail-to-work-when-being-called... 

0 Likes