How to change ecommerce currency sent to Google Analytics

PureTime
Explorer
47 1 10

Since I launched my shop in december 2020, the currency value sent to Google Analytics has always been the amount converted to USD.

However, my shop currency is DKK - and almost all customers checkout with DKK.

About a week ago I changed the the currency view settings in GA to DKK:

PureTime_0-1624602167239.png

However, all incoming orders since then are still being shown/converted into USD.

Does anyone have a clue how I change that?

 

0 Likes
MS-WEB-DESIGNER
Shopify Partner
2798 175 469

Dear @PureTime 

Hope this will help

  1. Navigate to the View that you wish to update 
  2. Once you are in the main report screen, select “Admin”  from the left sidebar at the bottom.
  3. Make sure the appropriate View  is selected and then click “View Settings“: 
  4. In “View Settings“, locate the “Currency Displayed As” option and select the appropriate currency that us relevant to your region: 
  5. Click Save.
0 Likes
PureTime
Explorer
47 1 10

Thanks - but that's excatly as I did as shown in my screenshot.

My problem is that new orders still is shown as the USD value but with DKK as symbol.

Actually - some days the amount is correct (DKK) - but other days the amount is - for some reason - converted to USD - without me changing anything.

0 Likes
MS-WEB-DESIGNER
Shopify Partner
2798 175 469

In your store admin currency is DKK ?

0 Likes
PureTime
Explorer
47 1 10

Yes.

Changed it Monday. Orders on Monday show in DKK in Google Analytics (GA).

Order from Tuesday show in USD.

No orders Wednesday.

Order from Thursday show in DKK.

I have no clue how it can shift like that.

The product sold on Tuesday was another one thank I sold one the other days, but I can't see why one product should send the currency converted to USD while the other ones don't.

0 Likes
Ireoluwa
Excursionist
73 3 5

Hello share your store link so i can monitor it and see the same error you are seeing for me to see into it

0 Likes
daniel9584
New Member
1 0 0

Hello,

Please try this steps, it's may help you.

  • Navigate to the View that you wish to update.
  • Once in the main report screen, select “Admin”
  • Make sure the appropriate View is selected and then click “View Settings“:
  • In “View Settings“, locate the “Currency Displayed As” option and select the appropriate currency that us relevant to your region:
  • Click Save.
0 Likes
PureTime
Explorer
47 1 10

Thanks.

That has been suggested several times in this thread. It IS set to DKK.

For some reason one type of products still show as USD.

0 Likes
PureTime
Explorer
47 1 10

Thanks - it's not visible on the storefront - as it's only in Analytics there is this strange issue

0 Likes