Issue with Sections

Highlighted
New Member
14 0 0

Hello Everyone,

Shopify introduced new feature "section" in theme which makes work life easier, but I am facing one small issue with it. Whenever I make changes in theme settings, some section's data gets disappeared (means that section gets removed from sections editor page) & you need to add it again. Anytime I make any edits in settings they disappear. This happened with 2 shopify stores I am working.

To avoid this issue, I tried to add that content using "General Setings" (which is old method) by adding those fields in settings_schema.json, it works on front end but when I visit theme editor, Sections Tab shows nothing (only loading boxes) Please see attached image for this issue & firebug shows 2 erros as follows:

1. The resource from “https://v.shopify.com/last_shop?shop=shopname.myshopify.com” was blocked due to MIME type mismatch (X-Content-Type-Options: nosniff).

2. TypeError: t is null in https://cdn.shopify.com/s/assets/online_store/design_mode/index-......js

Can anyone help with this? Thanks in advance!

- Suhas

 

0 Likes
Highlighted
New Member
2 0 0

I am also getting this problem and my section disappeared when I making copies of my theme as a backup.  When I tried to update my website the options that would normally show there disappeared.  Is this a bug?  None from my team made changes to the core code level.

 

Anyone else getting this issue?

issue.JPG

 

Thanks,

 

A

0 Likes
Highlighted
New Member
2 0 0

I removed my custom code from theme.liquid and it worked for me.

0 Likes