MailChimp app not connecting after disconnect

Tourist
5 0 1

Hi,

I was having issues with my MailChimp integration with Shopify, I changed the connected list and afterwards it didn't move past 'syncing'. I should have just disconnected and tried again but instead I deleted the app from the Shopify side and then tried to re-connect.

The re-connect seemed to go ok except I was not given a choice of list (I assume this is using saved data from somewhere). Then in Shopify everything looks normal, but in MailChimp it is as if no connection has been made.

Here are some screenshots.

 

 

Any ideas?

I'm only using the free MailChimp account so unable to get support through there.

Thanks,

Stu

0 Likes
Highlighted
Shopify Staff
Shopify Staff
33 0 4

Hi Stu,

Parker here from the guru team - ready to help! :)

By the screenshots provided, it does look like everything is connected properly. However, I would like to take a deeper look into your account. I've sent you an email from our end to the email listed on your forums account with some more troubleshooting steps.

I look forward to help you resolve this issue!

 

0 Likes
Tourist
5 0 1

Hi Nikki,

I responded to the email but thought I'd do so here to incase anyone else had any ideas especially regarding MailChimp since I don't really think its a problem Shopify side but happy if it can be fixed from there.

I decided to try setting it all up in Safari instead of Chrome just to make certain that no browser history was involved. But still the same issue. I've installed the app now. Its really odd, I can setup abandoned cart emails for the store and it lets me select the store that way but when I go to the connected site page it acts as if no site is connected.

I've put together a video (Unlisted) that probably explains it a bit better.

I tried to embed it but couldn't so here it is as a link.

https://youtu.be/yKhyPDTOQb0

Any ideas? My next move will be to move to a paid MailChimp account and contact their tech support since I'm assuming its a MailChimp bug of some kind.

Thanks,

Stu Clarke

1 Like
New Member
2 0 0

Hello Parker,

I am currently having the same issue as you. I'm looking for a possible solution in the web but can't seem to find one but I found this post from you.

Have you managed to fix the issue on your end? I was also trying to reconnect MailChimp to Shopify as there was an error. But after disconnecting and reconnecting, it shows the same result as what you've shown on the video.

Regards,

0 Likes
Tourist
5 0 1

Hi Dezdevdesign,

The issue was on the MailChimp side, the only way I could get it fixed was to subscribe to their product and use the help chat. They were very helpful and solved the problem within a few days, it wasn't straight forwards and could not have been fixed without someone being able to manually change connections.

Hope that helps,

Stu.

0 Likes
New Member
2 0 0

Hello Stuart,

Thank you so much for the response on my comment. I will proceed to contact them regarding this issue then. 

Thank you,

0 Likes