Remove Vendor / Minimal Theme

Highlighted
New Member
1 0 0

I've tried the explanations offered for a couple other themes -- Online Store > Themes > Customize Theme -- but there is no Collections option that I can see. Help? I want to remove the vendor name.

0 Likes
Highlighted
Shopify Staff
Shopify Staff
69 1 7

Hi Bonnie, 

David here, Shopify Guru. 

Within the Online Store > Theme Customisation Area, you should be able to remove the Vendor from each the Product Page and the Collection pages! 

To get to the 'Collection Page' settings, head into your Theme Customisation Area. On your webpage, click on one of the collections listed on your store. Your tool on the left should change to display an option called 'Collections Pages' here. 

Under the Collections Pages area, you should have a checkbox available that will allow you to disable the Vendor Tag here.

If you are looking to disable it on a Product Page, it would be the same process from the Theme Customisation Area. Click on a product, it will change your tool on the left to display another option of Product Pages. 

Once again, you should have some more options for changes to the Product Page. One of them including disabling the Vendor link as I pointed to here! 

Hope this helps you find it on your store :) 

David 

0 Likes
Highlighted
New Member
2 0 2

Hi,

I do not have any of these things in my Customize theme - I'm using Minimal as well.

Please see the attached screenshots. Could you please help me remove the branding on the product page?

Thanks!

Highlighted
Tourist
3 0 2

I'm running into the same problem as Catalin. There are no options when I click the collections.

Highlighted
Tourist
5 0 5

Nine of those screenshots match what's available in the actual minimal customisation. It appears someone removed the ability to edit what displays on the collection pages!

0 Likes
Highlighted
New Member
2 0 7

After searching for the solution to this and finding that most answers were out of date or didn't work, I figured it out. 

If you're using the Minimal theme, the check box no longer appears for hiding the vendor on the Product pages, although it does exist for hiding it from the Featured Collection when you're editing the Sections (Customize Theme->Sections>Featured Collections>uncheck the "Show product vendor" box). Someone pointed out if you could find the code in your CSS you could alter it, but then someone else listed the wrong CSS asset. Here is a screen grab to make it easier. 

  1. Go to "edit code"
  2. Go down to the Sections folder
  3. Open product-template.liquid
  4. Find or search for "vendor" in the text in this line                                                                    {% if section.settings.product_vendor_enable %}
  5. Change the word enable to disable
  6. Save and exit, et voila! 
Highlighted
New Member
2 0 7

I realized you also need to make THIS adjustment to hide the vendor in any specific collections. Above was to hide it in the individual Product pages. This is to hide the vendor in your specific collections. 

Go to Edit HTML>Sections>collection-template.liquid>then search for word Vendor, and change this line  "id": "vendor_enable",   to   "id": "vendor_disable",  (change enable to disable) 

Highlighted
New Member
5 0 0

Hi there,

I have the same problem, but can't find the code either. I dont have sections, but templates. In templates i can find the word ''Vendor'', but I dont see enable or disable anywhere. Using Apollo theme, fresh market. can somewone help? 

Attached a photo of the code. 

0 Likes
Highlighted
New Member
1 0 1

Thank you EP, that was exactly what I was looking for and the answer I needed for it to work. 2 years and still helping.

Highlighted
New Member
1 0 1

The "product vendor" option can easily be diabled without needing to modify the code.

  1. Login to your store.
  2. Click Online Store >> Themes
  3. Click on "Customise".
  4. On top menu bar or the preview pane your theme, select "Product Pages" from drop down menu.
  5. Click on "Product Pages" from left hand menu under "Header" again.
  6. Untick "Show vendors" option.
  7. Repeat Steps 2 to 3 and select "Collections Page".
  8. Click on "Collections Page" from left hand menu under "Header" again.
  9. Untick "Show vendors" option and click Save.

I know this post is old but posting a reply anyways in case anyone else out there still looking for an answer.