Swatches not updating even after uploading new png under assets

Highlighted
Excursionist
31 0 7

Hey,

 

Topic says it all :)

 

I've uploaded new colors.png (silver.png and gold.png) but the product swatches are still showing the old pngs (even these are deleted)

 

It's even more weird, cause when I delete silver.png and gold.png, the product pages and collection pages are still showing the old color swatches. (even without the files under assets)

 

is there some kind of trick to force my store to use the newly uploaded pngs?

 

thanks a lot all! 

0 Likes
Highlighted
Shopify Partner
1648 206 326

What's your store URL if you can share?

Sergiu Svinarciuc | CTO @ visely.io
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution!
- To learn more about the awesome stuff we do head over to visely.io or our blog
0 Likes
Highlighted
Excursionist
31 0 7

www.shoptopper.be (pw : topper)

store is 20% ready btw....

 

it also loads verrrrry slow :-( 

0 Likes
Highlighted
Shopify Partner
1648 206 326

So for this product https://www.shoptopper.be/products/keychain-men-keychains-classic-leather-car?variant=32171790565516 - there is a silver and gold swatch, can you post the png's that you have uploaded and expecting to see instead of the ones you currently see.

Sergiu Svinarciuc | CTO @ visely.io
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution!
- To learn more about the awesome stuff we do head over to visely.io or our blog
0 Likes
Highlighted
Excursionist
31 0 7

well i think i found the reason why they were not updating (correct me if i'm wrong cause i'm a nooby :-)

 

imo when you upload for example silver.png to the assets folder to use as color swatch, the frond-end itself seems to use silver_50x.png each time and that file i don't know how to replace cause i don't find it when i search for it.

 

The only way that fixed this for me was to duplicate the theme, use that duplicated theme (but don't open the front-end) and edit code and upload silver.png again to the assets folder (overwrite it). 

And then go to your store and you'll see your swatches updated.

At least this worked for me. 

 

or did i do something wrong here? 

0 Likes
Highlighted
Shopify Partner
1648 206 326

I think there was a client side caching issue, rather than an issue with upload/server side caching issue. This is why I asked the files you are expecting to see, to compare to what I was seeing.

Sergiu Svinarciuc | CTO @ visely.io
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution!
- To learn more about the awesome stuff we do head over to visely.io or our blog
0 Likes
Excursionist
31 0 7

Could be a client side cache issue, but i checked it on different browsers and different computers, is it still possible to be a clientside issue?

 

Also you were seeing the correct png's indeed, that because I solved the issue before you replied and you were already seeing the duplicated theme with the correct images...

 

It's a big hassle to overwrite 1 png for me, each time duplicating the theme etc etc. 

 

Does it overwrite correctly on your store?

0 Likes
Highlighted
Shopify Partner
1648 206 326

Gotcha. If you have tried it from the same location, might be a proxy cache issues. Yes, it works perfectly, and I haven't heard any other complaints. But yeah, might well be a subtile bug.

 

Are you still experiencing this issue?

Sergiu Svinarciuc | CTO @ visely.io
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution!
- To learn more about the awesome stuff we do head over to visely.io or our blog
0 Likes
Highlighted
Excursionist
31 0 7

Gonna try it from another location in 1 hour and I'll keep you posted ;) 

0 Likes
Highlighted
Excursionist
31 0 7

hi again,

 

i tried again, I did overwrite my silver.png with a pink version to test. I confirmed to overwrite the file in my assets folder.

When i go to the front end and clear my cache, i still see the old silver.png. So i think it's a bug, either in shopify or in my Impulse skin?

 

could you try to overwrite a swatch png in your assets folder? 

0 Likes