Vivaldi & Chromium Browsers No Longer Work in Shopify Admin

New Member
2 0 2

Hello - anyone else seeing this issue? - the Vivaldi and Chromium browsers no longer function in Shopify Admin. Seeing this error on login:

----
Your browser needs to be updated
You’re using version 1.96.1147.42 of Vivaldi, which is not supported by Shopify. You can continue using the current version, but some features may not work correctly.

If you are unsure of how to upgrade, we recommend using the Google Chrome browser, since it can update automatically.
----

NOTE: Vivaldi is actually on version 1.15.1147.42 (Stable channel) (64-bit) - not - 1.96.1147.42 as listed by Shopify. I've tried spoofing the user-agent....same issue remains.

And when you try to edit code in Shopify, the page never loads, just refreshes and you have to close the browser tab. Just started this last week. I contacted Shopify support and their answer is:  "Shopify, in it's current state, doesn't support Chromium or Vivaldi" and to just use Chrome or Firefox. Hmm...was working fine for years, just quit this week.

Another forum about this issue here: https://forum.vivaldi.net/topic/27780/vivaldi-just-quit-working-on-shopify

1 Like
New Member
2 0 2

So...finally heard back from Shopify and this was the response...note: I had the original ticket escalated, so the response is from the developer team.

_______

Shopify is constantly evolving and our platform is becoming more and more robust. As a result not all browsers can continue to keep up with the demands of our platform/admin.

Those browsers are not supported.

All I can say is that Shopify isn't trying to do this on purpose. If you would like to continue using Vivaldi and Chromium, I would recommend reaching out to them and ask them if there are any bugs that they are aware of. Otherwise, switching to one of the browsers that are able to support Shopify.

_______

Hmm... both Vivaldi & Chromium are widely used...and this just arose a week ago, after years of using both Chromium & Vivaldi without issue. Seems like a narrow path (and easy) to just force use of a few browsers, especially since both of the browsers mentioned are Chrome-based. Chromium is actually the non-commercial base for Chrome.

1 Like
New Member
1 0 0

Error currently reads:

 

Update your internet browser

You’re using version 2.7.1628.30 of Vivaldi, which is not supported by Shopify.

Try using a browser that automatically updates, like Chrome, Firefox, Opera, or Edge.

- - -

 

It is certainly within Shopify's power to allow the browser even if not "Supported."

 

Also the error message is wrong. "Try using a browser that automatically updates," which Vivaldi does. 

 

I'm sorry, but I simply can not be as productive the lesser browsers offered, and I can get more tools for less using other services. I think I will follow my browser to the competitor.

0 Likes
New Member
1 0 1

I just updated to the latest version of Vivaldi, which as was stated previously, updates regularly.

 

There's a serious philosophical problem with the developers here if they want to lock out updated, modern, and widely-used browsers.

 

Please remedy this.

1 Like