products not showing up in collection page

Solved
New Member
7 0 0

HI,

I have the same issue:

-I have created 3 products, 2 are already linked with a collection but 3rd one :there are no products in this collection.

I've tried to search in collection which I 've created, it says : there are no products in this collection, add or change conditions to add products..

-I've checked navigation/ menu item , there is only product which links with all products, also, I 've created in the navigation, the name of the collection I want to link.

I'd like to know how my product can appear in the collection ?

Thanks

Alex

0 Likes
New Member
1 0 0

I found the issue. If your products aren't active, they won't show until they are. It may say "draft" but go to the product and make it active. Hope this helps. 

Screenshot_20201121-134635_Shopify.jpg

0 Likes
New Member
1 0 1

Thank you so much! I had tried everything else and this is what I needed!

New Member
1 0 0

I wouldn't say this issue is "Solved..." This glitch is pretty bad... hope it gets fixed.. I went through every solution in this thread and nothing worked.

I added the collection, deleted it. Made active, removed tags, manually added items, did everything twice in different orders. Clicked check boxes to make active. Did everything in threads again in different orders... nothing.. the products wont show up on my collections page...

 

I final followed this one:

1. Check the boxes of the products that are not showing up,

2. Click the drop down "More Actions"

3. Select: "Add Available Channel(s)...

4. This schedules the product to be available in the next 30 mins (WHY SHOPIFY?!)

 

Still doesn't work.... I thought shopify was supposed to help us sell products? but how can I sell product if they wont show up? spent 1/2 day on this issue... 

0 Likes
Tourist
5 0 1

Hi everyone. I've been having this problem too.

I just figured out what my issue was.

I had not selected any sales channels for the products that were missing.

Click the product and click manage under 'sales channels and apps' then select online store.

I hope this might help someone who had the same problem as me. Might not be the right solution for everyone.

0 Likes
New Member
2 0 0

I am having this problem and my product doesn't even show up on my 'all product' page as well as my collection tab. It is labeled as active. Can you help me?

 

0 Likes
Tourist
4 0 3

In the Collection page you decide how you are going to choose products for the collection - automatic or manual.

If it is an automatic collection then you must specify that it selects products by name, tag, price, etc. It must match exactly. ie the product must be tagged with the same tag as you have specified, or have the same text in the title, etc.

If it is a manual collection, you add those items individually yourself by searching for them in the browse drop down.

You must then ensure that your "collection" is added to your menu bar by going to your Sales Channels on the main menu, selecting "Navigation" > Main Menu then adding where you would like it to appear.

We use both Manual and Automatic for our collections - for instance something you have all the time would be an automatic collection ie. All bags. I use a Manual collection for New Arrivals - this means I just go to the Collection, add the items I would like in, and remove those no longer relevant. This is easier than tagging everything as New arrival, then having to remove the tag.

I hope this helps.

0 Likes
Tourist
5 0 1

Thankyou Booktides

0 Likes
New Member
1 0 0

I’m having the same problem, products not showing up in collections the way they all have previously. And sometimes a collection show 18 items sometime 20 or as many as it feels like. I know for a fact all my tagging was don’t correctly 

0 Likes
Tourist
5 0 0

I think Monipupi and I were traveling the same collision course! Today, after wasting hours and hours with the same issue (item not showing up in the collection list as well as the Collection title not showing up on the product page) and after checking and re-checking the Auto / Page Title criteria, I sat staring at the product page in defeat. And then, there it was, glaring out from the Product Title ..one little character, a letter "s" ..making a word plural when it's not. So there ya have it, in literally 2 seconds all those hours of frustration came to an end. Just goes to show, the fix can never be too minute.

0 Likes