Adding section causes reload // server respond with 401 / theme_id = empty

Highlighted
New Member
2 0 0

Hello Community,

I'm pretty new to Shopify's theme kit and I hope I can address my issue in the correct manner. This is the scenario:

I have a couple of themes in my Shopify Backend. If I'm in customization mode since today I can't add new sections to my index page. I made a little screencast that illustrates the issue. I click on add section, then the backend reloads. It doesn't matter which theme I choose, it's the same in all themes. 

I checked the error in the console and I can see that there is a post request, that gets a 401. When I look at the URL that is called, then I can see that the parameter theme_id is empty. A screen within too.

Bildschirmfoto 2020-08-27 um 12.52.00.pngBildschirmfoto 2020-08-27 um 12.51.34.png

I checked if this issue is related to the browser I use, but it's the same in Chrome and Firefox, also stays the same after deleting cache, sessions, and cookies. 

I'm not aware that I made changes to the Theme that might cause this behavior, and I have no idea where to search for this error. I would be more than happy if anybody can give me a hint on this.

Thanks in advance

N*

 

0 Likes
Highlighted
New Member
2 0 0

In case someone runs into the same issue, I figured out that this behavior is caused by the add-on GDPR Legal Cookie. 

Once you accept the cookie settings in the active theme, the reload stops. You need to accept the cookies in the preview window that is in the same tab as the shopify backend. 

You can reproduce the issue when you delete all cookies, and everything in the cache. Then you reload the backend, and log in. If you open the preview of a not active theme and try to add a section, the reload will be hit. 

Once you switch to the active theme and accept the cookie settings, the behavior will stop.

I hope it helps anybody. 

0 Likes