Administrative part of the site is extremely slow

Solved
Highlighted
Tourist
3 1 1

Hi,

 

My store in the frontend is working fine for the customers, however, to make any movement inside the administrative is taking a loooooong time.  Printing a label for one product took me about 10 minutes, had to reload the page several times until I did it succesfully.  I thought it was my connection to the internet so I called Xfinity and upgraded my service (the whole family is now on the internet for most of the day), and now I have 1Gb download speed, nothing higher in residential service, and still having the same exact issue.  Is there anyone having the same problem? Or is just me. Info about the site:  Template with no changes since the openinig of the store in January, feeling issue since last 2 weeks, located in south Florida. Well, any suggestion on what to try would be appreciated.

0 Likes
Highlighted
Shopify Staff
Shopify Staff
462 28 147

Hi, @hdosurrego!

 

This is Rae from Shopify. Thank you for reaching out about the slowness you're experiencing in your admin. 

 

I appreciate you testing out your internet connection to see if this is the cause. Before you upgraded your service, did you have a chance to try accessing your admin from another network - like a data connection, or a different wifi network - to see if the slowness was occurring on that connection, too? Equally, have you reset your modem, or internet connection, since upgrading? If not, I suggest giving that a try. 

 

Can you also please confirm which internet browser you're using when you access your site? We have a list of our supported browsers here, so please make sure you're using one of these options, and you've recently cleared your cache. If you're already using one of these browsers, then I recommend testing out a different browser from the list to see if the slowness occurs on that browser, too. Visiting your admin from a Chrome Incognito window is also a great step to take. 

 

Additionally, does this slowness only occur on one device? To test this, please try visiting your admin from another computer. If this isn't an option, then checking out your admin from a tablet, or a mobile device, using either Apple Safari for iOS or Google Chrome for Android is a great troubleshooting step to take. 

 

Please keep me posted on how this goes. I look forward to hearing back from you and working towards a resolution! 

Rae | Social Care @ Shopify
Was my reply helpful? Click Like to let me know!
Was your question answered? Mark it Accept as Solution to help others locate the answer!
To learn more visit the Shopify Help Center, or the Shopify Blog.

1 Like
Highlighted
Tourist
3 1 1

Hi Rae,

Thank you for your complete reply. I have actually tried almost everything you suggested, from clearing chache, to different devices and to other operating systems as my change of internet service didn't work.  It was the same until I tried the incognito window. It worked, it moves a lot faster than with the normal browsing.  It feels weird though that I have to change the browsing mode to get more speed.  

 

Although I really appreciate your response, the regular browsing, which is the one that anyone use by default, is not solved.  Knowing that with the incognito browsing mode is working, do you have any idea what is going on?

 

Thanks a lot for your help.

 

Henry

0 Likes
Highlighted
Shopify Staff
Shopify Staff
462 28 147

This is an accepted solution.

Hi, @hdosurrego

 

I appreciate you following up with me and trying out the troubleshooting I mentioned. 

 

I'm glad to hear that your site is working correctly on Incognito mode, though I understand you'd like this to work on a regular browser too, so I can certainly offer some more steps to help achieve this. 

 

When you cleared your cache on your regular browser, did you also clear your cookies? If not, please give this a try to see if this resolves things. If you're using a Chrome browser, you can learn more about clearing cookies here. Equally, if you're using Safari, the steps for this are listed here

 

Can you please tell me a bit more about which devices you tried to access your admin from? If you used a mobile device or a tablet, I'm interested to find out which model you tried, and what browser you used on those devices. 

 

Lastly, did you have a chance to try visiting your Shopify admin from an entirely different network connection? In some cases, using another wifi network, or connecting to a data connection, can be used to further troubleshoot local issues and determine if this is the cause of the problem. 

 

Let me know how this goes! 

Rae | Social Care @ Shopify
Was my reply helpful? Click Like to let me know!
Was your question answered? Mark it Accept as Solution to help others locate the answer!
To learn more visit the Shopify Help Center, or the Shopify Blog.

0 Likes
Highlighted
New Member
1 0 1

I believe it is a problem with xfinity because I have the same issue either it runs really slow or it does not load at all. Unless i restart the modem then it works fine for 5 mins and then boom not working again. I spent 2 hours trying to fulfill one order because of this. I think the firewall protection in xfinity is blocking something.

1 Like
Highlighted
Tourist
3 1 1

This is an accepted solution.

Hi Rae,

Sorry for the delay response, I have tried other things, but definitely it has to do something with the browser, I am using now Firefox and everything is running smoothly.  I have cleared the cache, the cookies and try other devices, and Chrome is the only thing having the slow response with the Shopify store all across devices.  I believe now that it may be because I have a lot of extensions installed in the browser, I am a developer and also have an Amazon store, and all the Chrome extensions work in the background when you open some sites, that may be the reason but not sure.  As I need all the extensions to keep working in other stuff, my decision was to keep working the Shopify store in Firefox, which is a very good browser too, with no problems so far.  Thanks a lot for your attention to this matter, and if you find any other reason in the future that may help us to figure out this performance problem in this browser let us know.  Thanks again and have a great day.

1 Like
Highlighted
Shopify Staff
Shopify Staff
462 28 147

Hi, @hdosurrego and @AMC2020

 

Thank you both for following up on this. 

 

@AMC2020, have you tried to contact Xfinity about this directly? If not, I recommend reaching out to them and explaining your situation. Hopefully they can provide further assistance once you speak with them about the troubles you're experiencing. 

 

@hdosurrego, thanks for keeping me in the loop on this. I'm glad to hear Firefox is working correctly for you. The information you provided does lead me to believe that it could be an issue tied to Chrome, and potentially the extensions on this browser, like you mentioned. However, I'm interested to hear if you run into these same issues when using other wifi networks, or data connections. Did you have a chance to try connecting to a different internet network, and using Chrome to access your Shopify admin? If not, please give this a try and let me know how it goes! 

 

Best, 

Rae | Social Care @ Shopify
Was my reply helpful? Click Like to let me know!
Was your question answered? Mark it Accept as Solution to help others locate the answer!
To learn more visit the Shopify Help Center, or the Shopify Blog.

0 Likes