Either "offers", "review", or "aggregateRating" should be specified - Google Error

32 0 2

Oh, are you referring to this? https://help.shopify.com/en/themes/development/theme-editor/settings-schema


Interesting, I didn't know such thing was available.


@tim wrote:


it does not have to be hard-coded -- it's possible to add a checkbox to theme configuration, like "Apply Tim's fix for Product reviews" :)

So you can always revert to original code by unchecking it.


I would not expect the fix quickly -- as I said, it's complicated.

However, even when fixed,  it may take weeks (rather months) for Google to validate the fix, unfortunately and your products will be penalised  untlil it's finished...

One shop where I've applied my fix about a month ago -- validation is "looking good", but still 10 pending out of 21!

was available.

New Member
1 0 0
“priceValidUntil”, “aggregateRating”, “review”, “brand”, “url”, “sku”, “No global identifier provided” and “description”.
This is frustrating because except for “sku” and “global identifier” all other fields are filled in my product pages. Why is google search finding errors? Can someone help please? I am using Impulse theme. Store url is jeogem.com. Thanks.. :/
Shopify Partner
221 15 25


I have tested one product from the given link and I found that product meta has a total 28 warning error because it loads three times and some value they not able to get because it is not specified. It is a coding issue so if you want to solve it then please contact me on my email address because for this case I need to talk with you.

Reference Screenshot: 

You can contact me on:

Thanks & Regards
Akshay Vaghasiya

Shopify Expert | E-commerce Consultant
Email: akshayvaghasiya84@gmail.com
Skype: akshayvaghasiya84
 - Want to modify or custom changes on store hire me .
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
New Member
2 0 1

We're the store that Tim helped on resolving this issue a few weeks back. It's taken a while for Google to crawl the URLs and validate the fix, but they've now all cleared with no errors.


I had a basic understanding of what the issue was, but am not experienced enough with coding to be able to fix it. Tim was a great help and explained what he was doing at every stage - if there's anyone else reading through this thread to seek help with this issue, I'd do yourself a favour, save time and hassle, and get Tim on it!


Screenshot below from Google Search Console, showing the errors creeping in. Tim worked his magic early November, and eventually the errors have all cleared once Google has re-crawled the links and verified the new coding.

Screenshot 2019-12-15 18.47.59.png


1 Like
4 0 1

Been seeing this issue for a client of mine and at closer inspection, when running to code through Google's structured data validation tool: https://search.google.com/structured-data/testing-tool/u/0/


Unsure if anyone else has proposed a recent'ish solution for these errors (in the 11+ pages for this thread), but here is my 2 cents...


When I see what Shopify is outputting, it's clear they are in a circular logic.  Our custom theme has "Product", for which "Aggregate Ratings" is a property of.  But then they make the mistake of adding "Item Reviewed".  Where "Product" is a property of... and... then we start the loop again...


In other words, this is what Shopify Outputs:

  • Aggregate Ratings
      • Offers (Missing... throws the error)
      • Aggregate Ratings
        • ...etc
    • Item Reviewed

The actual reference is https://schema.org/Product


So the structure should be:

  • Product
    • Offers
    • Name
    • Image
    • Description
    • Aggregate Ratings
    • etc...

I changed our customized theme to properly reflect this, but the hack/temporary workaround involved changing the default output.  The offending code from Shopify is (and note the inconsistency with single and double quotes):


  <div itemprop='itemReviewed' itemscope itemtype="http://schema.org/Product">
    <meta itemprop="name" content="<YOUR PRODUCT NAME/TITLE>">

"http://schema.org/Product" should NOT be inside "aggregateRating".  That's a beginner's mistake.  How did this pass Code Review?



At any rate... once I identified the issue, I did two string replaces (so that when Shopify changes this, it won't break the code):


Locate where the output happens:

{{ product.metafields.spr.reviews }}

and change it to:

              {{ product.metafields.spr.reviews | replace: ' itemscope itemtype="http://schema.org/Product"', '' | replace: " itemprop='itemReviewed'", "" | replace: 'itemprop="name"', ''}}


Since there is no itemprop="review" for each review (because reviews are currently called as an AJAX call, which Googlebots does not make, we also get a warning for "The review field is recommended. Please provide a value if available.".

For accessing the Product Reviews themselves to do a proper output for the bots, I am still unsure how to get these as they are not accessible via API...  so.. still working on that...

1 Like
New Member
1 0 0

We are working too on SPR callbacks, but not news at the time. Follow your progress and will report about our

New Member
1 0 0

I've tried applying your code but GSC refuses to let me validate the fix.  I sure hope Shopify gets on to this sooner than later, but sometimes it feels like support is not their strong suit :(

4 0 0

Hi Visely-Team


Thanks for your great advice! I have another error popping up from aggregateRating
Error Message: thing is not a known valid target type for the itemreviewed property


Can you kindly advise how I can fix it?




Shopify Partner
1153 133 200

Hey @mtnshop79 you might want to have a look at - https://webmasters.googleblog.com/2019/09/making-review-rich-results-more-helpful.html; it looks like you have your review widget attached to a schema type that was dropped by Google in Sept 2019.

Sergiu Svinarciuc | CTO @ visely.io
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution!
- To learn more about the awesome stuff we do head over to visely.io or our blog
1 Like
4 0 0

@Visely-Team  Oh yes! You are right!

So, I need to get someone to put the review thing under 'schema.org/Product'? Do you have any tips for me?


I actually approached Shopify to have it solved! Hopefully, I'll get the answer soon!