How to fix Product Sitemap product submission issue

Ramesh-fehu
New Member
1 0 0

Can anyone tell me why this sitemap issue happen? By default, in the Shopify sitemap we get four new sitemaps like :

/sitemap_pages_1.xml 

/sitemap_collections_1.xml

/sitemap_blogs_1.xml 

/sitemap_products_1.xml?from=3879496777846&to=3936362856566

 

3.jpg

When We upload /sitemap.xml in the google web console at that time, all sitemaps are upload successfully.

7.jpg

 

 

but when we upload any new product  sitemap_products_1.xml?from=3879496777846&to=3936362856566 will change to sitemap_products_1.xml?from=3879496777846&to=3936362846868  and we can't find product sitemap in the google web console 

 

8.jpg

 

Is there anyone who help me to solve this product sitemap display issue! 

0 Likes
Max
Shopify Staff
Shopify Staff
571 18 83

Hi, @Ramesh-fehu.

 

This is Max from the Shopify Team.

 

I am moving your post over to a more relevant topic in hopes that you'll get some more expertise and responses for your query!

 

In general, this doc - Finding and submitting your sitemap, is the best place to learn more about how to submit your sitemaps to Google for review. The sitemap.xml file contains links to all your products, product images, pages, collections, and blog posts, so, you shouldn't need to submit additional files for specific pages. 

I hope that this helps point you in the right direction for next steps! Let us know if you need anymore clarification.

 

Cheers,
Max

Max | Social Care @ Shopify
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes
mjaljassim
Tourist
8 0 0

Hey, everyone 

 i have problem with submitting sitemap to google console "sitemap_products_1.xml " ,

https://proteinkw.com/products/sitemap_products_1.xml

www.proteinkw.com

 

0 Likes
VBDSaz
New Member
1 0 0

I am having a similar problem. Google is not reading the product_1 sitemap. I have no idea whether or not it is because of the from and to attribute. I am also struggling to understand why the from and to attributes exists as there is no value in the xml from or to the values.  

0 Likes