I got an app bridge error when using resource picker.

Solved
Unih
New Member
2 1 0

Hi there, 

I have an embedded app using the polaris resource picker component with the app bridge to select products.

And since I deployed a new update of my app last week. Some of the merchant's shops got an error from the app-bridge. But most of them don't.

The update is about some UI changes and doesn't upgrade any library. Not sure what happened there.

Does anyone know how to deal with this error?

I think it is not related to the library version because the app works normally with most stores.

All the shop is with the same access scope.

Screen Shot 2021-06-15 at 2.53.20 PM.png

 

0 Likes
Unih
New Member
2 1 0

This is an accepted solution.

This issue has been resolved. This error message means my account doesn't get the read product permission to use the resource picker. 

0 Likes