Infected with HTML Refresh meta tag

Solved
Highlighted
Tourist
6 1 0

Hello All, 

I'm having a funny problem and can't find any solution for it and wanted to know if anyone is facing the same issue.

I can't access my website on my PC but others can with no problem, I tried every trick in the book and nothing helped, I even reinstalled my windows 10 and the problem is still there.

Here is a short clip showing the problem, can you please let me know if this is a virus and how to fix it? Thanks


https://streamable.com/y5x0hh

0 Likes
Highlighted

I can't access it either, the people who can probably are able to because they are accessing an older version of the website (cache). 

I am unable to diagnose it without taking a look at the code, did you hire anyone or injected any custom code?

If you want to get it solved please reach me out via email.

Kind regards,
Diego

◦ Problem Solved? ✔️ Please click on Accept as Solution and like.
◦ Needing urgent help? I am currently available for hire, same day response guaranteed: diego.boarutto.fortes@gmail.com
0 Likes
Highlighted
Tourist
6 1 0

I've tested the website via https://geopeeker.com & https://shotsherpa.com/

and the sites opens from different locations with no problem, so I don't think it has to do with the cache, and I don't think it has nothing to do with the the theme, because I've changed my theme just to check and the problem did not go away.

and here is prove that it's working from different locations :

Capture.PNG

 

 

0 Likes
Highlighted
Tourist
6 1 0

Ok, problem solved temporary.

The problem was due to the new IP address format, to fix this issue go into the setting for your network card, you should have both IPv4 and IPv6 checked in the list, 

Uncheck the v6, and restart your computer and the problem will be fixed.

The main advantage of IPv6 over IPv4 is its larger address space. The size of an IPv6 address is 128 bits, compared to 32 bits in IPv4.

You will not face the problem if you connect via WIFI , this only happens if you connect via ethernet cable.

The Question now ; is this a Shopify problem or Not ? has anyone faced the same issue? 

 

ethernet-card-property.jpg

 

 

0 Likes
Highlighted
Tourist
6 1 0

After doing more tests, it seems this is not a Shopify issue at all, this problem is related to the ISP (router) , now why is it only happing to my website that I need to find answer for.

The problem occurs when connecting directly to router via cable or wife, and in both cased an IPv6 address is created.

Will keep you updated on this issue.

Take Care

0 Likes
Highlighted
Tourist
6 1 0

This is an accepted solution.

Finally SOLVED.

Shopify had nothing to do with the problem , it was my hosting provider (hostinger.com) , so I simply moved to another hosting provider and everything worked fine. 

tyt

0 Likes