Picture not showing on FB Posts

Highlighted
New Member
6 0 0

When I try to add my website to a FB post, it shows no image. Like I literally get a blank box with a 'No Image' message. Why is FB not pulling an image for my site and how do I fix this?

 

Thank you!

0 Likes
Highlighted

Hello ,
Please share your site url.
So that i can check and provide you exact solution here.

Want to modify or incorporate custom changes on store, Hire us
If helpful then please Like and Accept Solution .
Email: pallavi@oscprofessionals.com
Skype : oscprofessionals-87
Whats app
Free Website Review and advice for sale from Shopify Conversion Experts | Shopify Private App | Custom Theme Development | Custom Modifications In To Shopify Theme | Shopify SEO ; Digital Marketing & amp | Site Speed Optimization | Performance Site Audit
0 Likes
Highlighted
Shopify Staff
Shopify Staff
754 42 153

Hey, @Elizabeth_Yelen !

 

Katy here from Shopify. I hope all is well with you!

 

As @oscprofessional mentions, sharing your store URL would be incredibly helpful, as it would allow Community members to dig into this with you. 

 

If you prefer not to do so just yet, or to further analyze the cause yourself, there is a helpful debug tool that Facebook provides here

 

You can pop your URL in this bar for the tool to then scrape. This can offer you additional information on the images that you have used, and why they may not be appearing. 

 

I hope this helps!

 

Cheers,

Katy

 

 

0 Likes
Highlighted
New Member
6 0 0

Whisperingtree.net is the url. Same problem persists the debugger, I just don't know where to put in the missing picture or how to tell it where to find a pic.

 

Thanks!

 

 


@Katy wrote:

Hey, @Elizabeth_Yelen !

 

Katy here from Shopify. I hope all is well with you!

 

As @oscprofessional mentions, sharing your store URL would be incredibly helpful, as it would allow Community members to dig into this with you. 

 

If you prefer not to do so just yet, or to further analyze the cause yourself, there is a helpful debug tool that Facebook provides here

 

You can pop your URL in this bar for the tool to then scrape. This can offer you additional information on the images that you have used, and why they may not be appearing. 

 

I hope this helps!

 

Cheers,

Katy

 

 


 

0 Likes
Highlighted
New Member
6 0 0

I've shared my url and no replies?

0 Likes
Highlighted
Shopify Staff
Shopify Staff
754 42 153

Hi, @Elizabeth_Yelen !

 

My apologies for missing this post, and for the delay in getting back to you!

 

Thank you for sharing your store URL. I have taken a look, and it appears that the image is not being pulled through as there is no image set. Let me show you here.

When sharing products, collections or pages, the image that is pulled through is the featured image for that page. However, your homepage works a little differently. Instead, this pulled from your 'social sharing image' in your theme customizer. You should be able to access this in your: Admin > Online store > Theme > Customize theme > Social Media > Social Sharing image. (Though this may vary slightly, depending on your theme).

 

10-38-e6n9h-sli8c

 

You can also adjust the text that is shared here too. This is located in your: Admin > Online store > Preferences > Website SEO.  If you could navigate to these areas of your admin, you can then add your preferred image and site description. I do suggest to clear your cache after doing so. 

 

I hope this helps - do feel free to let me know how it goes for you. 

 

Cheers, 

Katy

 

0 Likes
Highlighted
New Member
1 0 0

Hi,

 Same issue here. Have you already fixed this?   How did you fix the error? Thank you 

image error.png

0 Likes
Highlighted
Shopify Staff
Shopify Staff
754 42 153

Hey, @zenn !

My apologies for the delay in getting back to you here. A great first step in determining the cause (before proceeding with a fix) is seeing what Facebook's developer tooling tells us. 

Let me get you the link to help with this. I suggest testing this with a URL from your store here to see what result is displayed.  If you need a hand at all feel free to let me know.

Cheers,

Katy

0 Likes
Highlighted
New Member
2 0 0

I'm having a similar issue with Facebook refusing to pull blog post featured images (which it always used to do fine), the FB debugger tool throws this error but I don't know what it means?! Please help this is super annoying!

Warnings That Should Be Fixed
Missing Properties - The following required properties are missing: fb:app_id
0 Likes
Highlighted
Shopify Staff
Shopify Staff
754 42 153

Hey, @Zoltan3 !

 

Thanks for joining in here, and sorry to hear you are having difficulty also. 

I have checked on this for you and the error you are seeing is displayed only if you have a website associated with a Facebook app.

17-26-spc9l-cnf16

This warning means that a fb:app_id has not been specified in the open graph tags in your theme. If your website is associated with an app, you can add the following open graph tag to your themes code:

<meta property="fb:app_id" content="your_app_id" />

We have some info to help you with this here and also here.  Note: you will need to replace the text "your_app_id " with your own app id. 

 

If your website is not linked with a Facebook app, you can ignore this message.

 

If it is not linked with a Facebook app/ if the above does not work for you do let me know and I can take closer look. I would, however, need you share a link to your blog/ a link to the search results from the Facebook Debugger tool. 

 

Cheers, 

Katy

 

 

0 Likes