Product Page Issue - Product image not appearing.

Highlighted
Tourist
12 0 0

Hi!

I'm not sure if there's anyone that have experienced this before.

But all of a sudden, our site (http://estore.novita.com.sg/) has this random issue that is is happening on the product pages. The product images on the product pages are not loading, it just show a large white space, only showing the product option and if you scroll further down, you will see the product description section. To gain access and have the page properly loaded up, the users must refresh their page on the device they are using. (refer to screenshot - https://cdn.shopify.com/s/files/1/0221/5300/3080/files/screenshot-shopify.jpeg?v=1594120155)

It is not specific products that are affected. This happens at random times to random products.

Issues persist on Chrome, Internet Explorer, and Safari on desktop, Safari & Chrome on mobile, Chrome Incognito window. 

Also, on Mobile, at the Home Page, the dropdown link on our product menu and the dropdown on the footer links are not clickable and able to drop down suddenly. If we click for it to load into any other pages in the site, and go back to the homepage, this issue would be fixed. But on first load, this issue appear.

All these issues only happened last week and we did not install any new apps nor updated our store theme.

Store Theme: Turbo Theme
Product Page: We are using PageFly

Wondering anyone out here able to provide any advice or have experienced this before?

0 Likes
Highlighted
Shopify Partner
480 60 78

Checked site, looks ok right now.

- Was my reply helpful? Click Like to let me know!
- Was your question answered? Click Accept as Solution

Skype : lokendra.panwar1
0 Likes
Highlighted
Tourist
12 0 0

Hi @Propero ! Yes I just managed to get it sorted out with Pagefly's technical team for the product pages.

But for the dropdown menu, they are not able to help, mentioned that is not a Pagefly issue.

Till now, I am still facing the issue of dropdown menu on Homepage not working in mobile site. In desktop site, it works perfectly.

Any idea or advice for us on how to fix this?

0 Likes