Product images not displaying

Highlighted
New Member
2 0 0

example on live store.PNGexample on upload page.PNG

 

 

The website is homeappliancesdirect.com.au

I can't figure out what's wrong, i've tried naming differently, adding alt-text, uploading one and saving then the next, still unfortunately no luck. 

It acts differently for different products, sometimes showing 1, 2, 3 or 4 but usually not more than that. The hero picture always shows but the rest is to chance.

Any help would be much appreciated.

0 Likes
Highlighted
Shopify Expert
9978 110 1787

What is the theme you are using?

Have you (or someone) made code changes to it? If not, reach out to whoever made the theme as this is likely a bug in the code.

You could test to see if its code related by first installing a fresh version of that theme. Remember to NOT make it published. Preview that theme, and if the issue remains it's almost positively the theme code. To test further, install a free theme from the theme store and again do not publish it. Preview that theme and if that one works you've narrowed down it to a theme code issue.

I know this isn't a super useful reply but without seeing actual theme code there's going to be some guesses and assumptions made.

It's far, far less likely to be related to ALT tags or the upload itself.

 

★ Winning Partner of the Build a Business competition. ★ http://freakdesign.com.au
0 Likes
Highlighted
New Member
2 0 0

Thanks Jason, appreciate the response.

Theme: https://themes.shopify.com/themes/symmetry/styles/beatnik

I'm really hoping I don't have to start on a fresh template if I can avoid it, a fair amount of custom work has been done but nothing to the image section in question.

Any other suggestions are much appreciated, thanks again.

0 Likes