Social Share Image no being used with go daddy domain?

TheOvalPawffice
New Member
1 0 0

I registered my domain with godaddy before I setup my store. When I link to the store on socials with theovalpawffice.com it shows a blank image but if I use the-oval-pawffice.myshopify.com my selected image shows. Is there a way to fix this?

0 Likes
Julie
Shopify Staff
Shopify Staff
853 69 207

Hi, @TheOvalPawffice!

Julie here from Shopify Support.

First off, I just wanted to say that I absolutely love your business name. I'm also glad to see that you're working on adding a social sharing image. This is a great way to enhance your brand when your store's URL is shared on social media. 

Generally speaking, the fact that you are using a third-party domain shouldn't have any effect on your social sharing image. This is because the image is added directly through Shopify; since your GoDaddy domain seems to be properly connected, it's safe to say that the issue isn't with the domain itself.

When setting up your social sharing image, did you make sure to follow the instructions outlined in this help doc? There, you'll discover that the social sharing image should be added in Online store > Preferences

It's also important to note that some themes actually have a built-in social sharing image setting, which you can access in Online store > Themes > Customize > Theme settings. If your theme offers this setting, then it will always override any social sharing image settings from Online store > Preferences. When looking at your Theme settings, do you see a social sharing image setting there?

Another potential reason why you may not be seeing any image at all when you sharing your GoDaddy domain could be because you are sharing that particular link for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

If this is the case, I suggest using the Facebook Sharing Debugger to refresh the information that is saved for your page links. Keep in mind that it will take some time for Facebook to update this information on their end, so don't be alarmed if you aren't seeing the image show up right away. Other social media platforms offer similar tools, so if you can let me know where else you are experiencing this issue, I'd be happy to dig those up for you. 

I should also mention that what you're experiencing is a pretty common issue and there's actually another forum post that covers this exact topic right here. If you are still stuck, then I suggest reviewing that particular thread, as you should find some pointers there to help guide you in the right direction.

Let me know how that goes!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

0 Likes

Just use Facebook debugger to scrape the url you're going to share: https://www.theovalpawffice.com for a few times and it should be ok. Facebook debugger is buggy. 

SPO - SEO App to research keywords & edit social link preview
0 Likes