Subdomain is Not Working

3 1 0



I am getting an error message with my subdomain. I want my shopify store on a subdomain because my root domain is set up as a wordpress site.


I was able to connect this yesterday and it was working fine. Then suddenly it stopped working out of the blue.


I get this error from shopify:


CNAME entered incorrectly

Check that you've entered the required values, and verify your connection again.


CNAME (shop) 

Current value: [Empty]
Required value: 
I have entered my CNAME record correctly because it was working fine before. I tried deleting my CNAME and re-adding it, but it still doesn't work. For some reason Shopify is not reading my CNAME from my domain. Does anyone know how to fix this?
3 1 0

This is an accepted solution.



Finally after many hours, and endless headaches I found a solution! 


This solution is for those who are hosting their root domain on a different hosting provider, and want to point a subdomain to their shopify store.


  1. Go to your domain registrar
  2. Open the Domain Manager
  3. Click the domain you are working with
  4. Enter your DNS management settings (Ask your registrar if you don't know how to do this)
  5.  Add New A Record.  Enter the full subdomain name, in my case it was “”. Point it to the IP address for Shopify, which is:
  6. Add a CNAME record for your desired subdomain. For example: Shop, then point it to
  7. Connect your subdomain in your Shopify store settings

This set up should let you use both your subdomain on shopify and keep your root domain working on your main site.

New Member
1 0 0


I'm trying to connect my subdomain ( to the shopify shop maintaining the root domain on the other server, as well. The provider is Aruba.

I've tried with this solution of yours but in the DNS panel I can't insert the same host record both as A Record and CName; so if i create a record with the shopify IP address, I'm not able to create the same record which points to in the CName space.

Using just a CName record doesn't work since I get the same error message of the guy above. Neither works creating just the A Record.

So what now?

Thank you in advance for your help!