FROM CACHE - en_header

Facebook pixel

MihaiSj
New Member
3 0 0

Hello, 

i have used minimal theme for over two years and everything was good. Decided to upgrade to a better theme with more options. 
after i installed the new theme including facebook pixel  everything seemed fine all works, pixel is recognized by facebook and collects all data however the conversion rate dropped with 90% and altho i tried same campaigns the targeting seems to not work at all as it used to be. 
has anyone else experienced something like this? 
can theme you have influence how good the pixel is working? 
thank you

Replies 4 (4)
Niki_K
Shopify Partner
323 33 87

Hi @MihaiSj,

 

I don't think that theme can influence the performance of the pixel so significantly. Have you tried the Pixel Helper and tested the events in Business Manager? 

 

How did you install the pixel to the new theme? Through the Facebook Channel App or manually? 

Send me a link to your store to niki@hey.com and I'll help you out.
For more info what I do, visit my agency website ecommercepot.com or my personal website nikikozak.me.
MihaiSj
New Member
3 0 0

The pixel is installed through channel. 
i have helper installed . 
the events recorded on events manager is higher than the actual ecents on shopify that is one issue i noticed. 

Niki_K
Shopify Partner
323 33 87

Hi @MihaiSj,

 

discrepancies in data from Shopify and Facebook are very common. Btw. It's hard to say where the problem is without having access to the both analytics.

 

Have you changed the ads recently? Plus, one more assumption – the new theme layout can be very different from the old one and some repeated customers aren't used to buy on the shop with the new theme layout and might leave...? Just one more thing which came to my mind.

 

Otherwise, I would keep testing the events, make a test order if everything is fired correctly and give the ads a few days to learn. The landing page has changed with the new layout and since Facebook algorithm is also counting the landing page score, it might take some time before the ads start being delivered as before. 

Send me a link to your store to niki@hey.com and I'll help you out.
For more info what I do, visit my agency website ecommercepot.com or my personal website nikikozak.me.
MihaiSj
New Member
3 0 0

Thank you, it is fixed now. 

it is not from the theme. 

i got some help from and seems that the pixel had some duplicate events for some reason.