Google Remarketing Tag - To validate please enter the feed ID?

Jennywatt
Tourist
4 0 1

Hi! 

Im wondering if someone can help me with a few issues to do with google ads, remarketing tags and audiences source issues on my site.

I am in the process of double checking all my google tags on my shopify store. We have been selling online via google ads and recording in analytics for some time. 

  • Currently the google ads tag is green, analytics blue (apparently this is okay - it is using the built in analytics feature in preferences) and then the remarketing tag which is blue. 

On tag checker it is saying "To validate please enter the feed ID?" I have google merchant but none of my feeds and products on merchant (which i sell on google shopping currently) show product feed IDs or numbers. it is literally just individual product IDs in a list and then the name of the lists. I have also tried using my google merchant account number but that doesnt work either. 

My tag looks like this - perhaps i have not completed the tag properly or don't understand what the values should be for my site.


<!-- Global site tag (gtag.js) - Google Ads: 817140867 -->
<script async src="https://www.googletagmanager.com/gtag/js?id=AW-817140867"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());

gtag('config', 'AW-817140867');
</script>
<script>
gtag('event', 'page_view', {
'send_to': 'AW-817140867',
'user_id': 'replace with value',
'value': 'replace with value',
'items': [{
'id': 'replace with value',
'google_business_vertical': 'retail'
}]
});
</script>

The other issue which must be related to the above is my audience sources have an issue on adwords which reads:

Your campaigns can't tailor dynamic ads based on user activity when your audience source doesn't send the required parameter. Make sure the required parameter is being sent correctly. Your audience source may not have the required parameter for your business type on all relevant pages or events.

The adwords team havent been able to help via chat so if anyone else has any ideas that would be great! even if its just helping me to correct the tag

 
Replies 4 (4)
nsiddiqui
Tourist
3 0 1

Hi - did you ever find a solution to your error. I have exactly the same but can't find a solution anywhere? 

WeDoTheStuff
New Member
20 0 0

Hi @Jennywatt,

Your pixel setup is not complete, you didn't replace the string with the dynamic values to populate on everypage.

We understand it could be a pain in the @#! to implement Google's dynamic remarketing pixel, so that's why we've created an app to do it for you.

It fires the right snippet with the right attributes and values every time.

Check it out.

https://apps.shopify.com/dynamic-remarketing

If there's anything to customize on your site from our end to make it work, we can do it for you.

Ender
New Member
1 0 0

Did you ever find the answer to this? I'm having the exact same issue. I've looked in all the Shopify literature and been googling for hours but no one can simply answer this question. I have the same error message as well.

Jennywatt
Tourist
4 0 1

So I went on to google merchant and waited in the online chat help

we booked in a share screen appointment and they basically did it for me honestly the google team can be amazing but it can take time but I would advise doing that as the code they created to go into the theme was length and it’s not something I came across on google ever