Image Alt text

FedericaB1
New Member
2 0 0

Hi there!

I'm having an issue with image alt text. I have added  all the alt text on shopify, either through clicking the image (for products and collections), adding the alt text and then saving it or through the actual html on blog posts and pages. But on reports from Ahrefs still shows that those images don't have alt text and by inspecting the page it actually doesn't show alt text.

Do you know why that's happening? It's been over a week now that I added them.

Thanks to anyone who can support me.

Replies 11 (11)
Edward-Newgate
Shopify Partner
504 22 61

Hey @FedericaB1 

I think you have made something wrong in the process. To check what happened with those alt texts, you should add again for some images and test. By the way, I think this guide: How to Set Image Alt Text on Shopify would be useful for you.

Hope it helps!

Was my reply helpful? Click Like or Mark it as an Accepted Solution to let me know!
FedericaB1
New Member
2 0 0

Hi @Edward-Newgate ,

As I explained above, that is exactly what I did. It's quite Intuitive as you press on the image of products or collections and it ask to add the Alt text and then you save it. 

In addition, for the images in the blog and page, I have added the alt text in the HTML code. But still when inspecting the pages it doesn't show any Alt text.

Any other thoughts?

Henry-Chinaski
Tourist
9 0 1

Try crawling the site with Screaming frog, it will show site errors.

JacquelineN
Tourist
5 0 1

I am having a similar issue, did you ever find  a way to fix this?

Niki_K
Shopify Partner
227 24 66

Hi @JacquelineN,

if you check the code in your browser, can you see the alt attribute? Is it empty or not? Could you provide a screenshot?

Send me a link to your store to niki@hey.com and I'll help you out.
For more info what I do, visit nikikozak.me
JacquelineN
Tourist
5 0 1

JacquelineN_0-1634661767468.png

Yes, you can see the attribute, but it is empty.

Niki_K
Shopify Partner
227 24 66

Hi @JacquelineN,

thanks for sharing the code! So, I guess the problem might be in the code itself since the specific alt attribute isn’t rendering. I would check the corresponding liquid file to see how the code is written.

Send me a link to your store to niki@hey.com and I'll help you out.
For more info what I do, visit nikikozak.me
JacquelineN
Tourist
5 0 1
I am not really sure what I am looking for in the code. Is this something
that you can help me with?
Niki_K
Shopify Partner
227 24 66

Hi @JacquelineN,

I can have a look if I can figure it out. Just send me the link to your site and the name of the theme you’re using.

Thanks!

Send me a link to your store to niki@hey.com and I'll help you out.
For more info what I do, visit nikikozak.me