My Meta Pixel is not showing Add to Cart & Initiated Checkout events

Chad77
New Member
4 0 0

I've been warming up my Meta Pixel over the last week. I've noticed some volatility in how reliable the Shopify Integration with the Meta Pixel is on my site. Specifically, the only Standard Event being triggered correctly on my site is ViewContent. Every event further down the funnel isn't registering. Obviously, this is bad for Meta's ability to optimize my ad spend.

 

In the 'Test events' tab of the Events Manager on Meta, I can see that my Add to Cart and Checkout buttons are registering as 'Button click' events with buttonText being 'add to cart' and 'check out'.

 

I don't think I've made any custom code edits on my site that would causing this lapse in data being pushed from Shopify to Meta. And I've confirmed with both Shopify and Meta multiple times that my setup of Shopify / Meta integration looks complete and accurate. So it should be working.

 

Anyone know why my button clicks aren't registering as Add to Cart, Initiated Checkout, etc events with the Meta Pixel?

 

Screenshot 2023-07-10 at 12.34.29 AM.pngScreenshot 2023-07-10 at 12.32.30 AM.pngScreenshot 2023-07-10 at 12.29.08 AM.png

Replies 6 (6)

Josh_Uebergang
Shopify Expert
1012 43 269

How is your pixel set up? If you provide the site, someone can review and provide more insight. I would have.

Run Google Shopping ads? Get the free definitive guide to Google Shopping for Shopify (no optin required): https://www.digitaldarts.com.au/google-shopping
Chad77
New Member
4 0 0

Hi Josh, I wasn't sure what level of information to provide publicly. My site is gruns.co

 

The pixel is set up through direct third party integration between Shopify and Meta.

 

Screenshot 2023-07-10 at 2.08.07 AM.png

felipemoruzzi
Visitor
2 0 2

I have the same problem...did you solve your issue? could you share the resolution?

Chad77
New Member
4 0 0

Hey there, no solution from anyone yet. Still nothing from Shopify or Meta to resolve the issue. Which theme are you on? I'm on Refresh. And do you mind sharing your store URL? I'm curious if you're on the same subscription app too. Would be helpful for me to dissect what's going on.

Fx99
Visitor
1 0 0

Hey @Chad77 did you find a solution? Would you mind sharing here please as I'm currently facing the same issue

Chad77
New Member
4 0 0

I wasted several weeks trying to solve this directly with Shopify and Meta. No result. I onboarded with Elevar and connected through their improved tracking and the issue was resolved immediately. Just use Elevar. We wouldn't have a business without Elevar, as nothing worked from Shopify or Meta. https://www.getelevar.com/