Welcome email automation does not work

jorrgett
New Member
4 0 0

Hello,

 

I've set up the pre-built marketing automation for new customer newletter sign up.

Having in mind I have different ways to sign up: via checkout process, pop-up window, make.com integration...

 

So far it works randomly, just once when a customer did the checkout.

 

 

Replies 6 (6)

Dirk
Shopify Staff
2179 244 493

Hey, @jorrgett 

 

Happy to help. Just to confirm, what email marketing app are you using?

Dirk | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

jorrgett
New Member
4 0 0

Hi @Dirk ,

Thanks for your reply.

 

I am using this app: https://apps.shopify.com/shopify-email?locale=es

And this is my automation flow:

jorrgett_0-1699385042440.png

 

Dirk
Shopify Staff
2179 244 493

Gotcha. Have you been able to confirm where a visitor/customer has subscribed to the email marketing and it did not trigger this series of emails? Any screenshots you can provide would be great. For example, customers who checkout have the ability to opt-out of subscribing for email marketing if they choose to not want to participate. This is why you may see for example, 3 people check out, but if two of them opted out, it would explain why you have only seen the one come through for email marketing.

 

If there is anything else I can help you with, please let me know.

Dirk | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

jorrgett
New Member
4 0 0

Hi @Dirk ,

I registered myself via welcome pop-up from Rivo and make.com interface. I does register my emails (with email marketing enabled), however flow is not triggered. I’ve always used different emails (running out of them already)

jorrgett
New Member
4 0 0

hello @Dirk ,

 

I am attaching more data:
1. Flow with the runs (only 1):

jorrgett_0-1699562231610.png

2. Here is an example of someone who subscribed today:

jorrgett_1-1699562324348.png

 

3. Another from yesterday:

jorrgett_2-1699562381652.png

 

And as you could see before, there is no run for these last 2 customers.

Can you please support? I am getting into trouble since I promised a discount code when subscribing (contained in the emails from the flow) and is currently not arriving to the customers!!

 

Dirk
Shopify Staff
2179 244 493

Appreciate your patience, @jorrgett.

 

That does look strange. It looks like we'll need to access your account in order to resolve this issue.

While we're not able to provide account-specific support via community at this time, we'd be happy to continue assisting you through chat support. Please visit our help center and login for assistance.

Dirk | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog