usedelivery group is not working

ZeeshanSigma
Shopify Partner
5 0 0

whenever i'm trying to use the usedeliverygroup library in my checkoutui extensions it throughs an error
Screenshot 2023-07-25 at 2.00.17 PM.png

Replies 3 (3)

SBD_
Shopify Staff
1829 270 410

Hey @ZeeshanSigma 

 

Thanks for reporting this. I was able to replicate and had to update the package.

 

Can you ensure that the @shopify/checkout-ui-extensions-react package is at least version 0.27.1 in the extension folder’s package.json?

Scott | Developer Advocate @ Shopify 

ZeeshanSigma
Shopify Partner
5 0 0

I'm using 0.26 should i upgrade the pakcage or extension? what's the command to upgrade?

SBD_
Shopify Staff
1829 270 410

Change the version in the extension's package.json file and then run `npm install` from the extensions folder.

Scott | Developer Advocate @ Shopify