Would anyone know why my shopify app (still in dev) has started requesting a path of /socket ?

Danh11
Shopify Partner
81 2 32

When I launch the app in admin, the app polls a path of '/socket' and this path does not exist.

 

I think it started when I made some changes to the URL's to the toml file (but also could have been just a coincidence). Even when I stash my changes in git and run on the last commit (which was not doing this), it still happens.

 

I am running a cloudflare tunnel via the CLI, which my app URL points to, and it's been working fine before this.

It does not happen if I set automatically_update_urls_on_dev to true.
It only happens when I use my own app URL via the tunnel.

I have checked in another browser and also on another store in case it was a cache issue from a misconfigured TOML file at one point.

Nothing about my environment has changed (that I know of).
The only third party we're introducing is cloudflare's tunnel, but I can still ping my app with the URL of the tunnel.

 

For what it's worth, my app has a shopify.app.recommendations-extension.toml file and a shopify.app.toml file.

I've ensured both files have the same configuration.
Only the shopify.app.recommendations-extension.toml gets updated when automatically_update_urls_on_dev is set to true. Is this normal?


This app originally started out as the remix app template.
I then installed checkout extensions on it, which created the shopify.app.recommendations-extension.toml file.

 

I also occasionally get the error Oauth error invalid_request: The redirect_uri is not whitelisted when trying to launch the app (since this issue has started). This doesn't make sense as I am replacing only the URL when switching from the randomly generated URL's (which work) to my own URL.

 

Anyone know what might be happening?
I'm wondering if it might just be an error on Shopify's end which may resolve itself.

 

ps. We still need a location for App Dev in the partners/dev section on this forum. I realise posting in Extensions isn't the right spot for it 🙂

Reply 1 (1)

Danh11
Shopify Partner
81 2 32

I have tried using an ngrok tunnel instead of creating one through the cloudflare cli, but still the same issue.

For what it's worth, this is my TOML file

 

 

 

# Learn more about configuring your app at https://shopify.dev/docs/apps/tools/cli/configuration

name = "***"
client_id = "***"
application_url = "https://tunnel-url.com"
embedded = true

[access_scopes]
# Learn more at https://shopify.dev/docs/apps/tools/cli/configuration#access_scopes
scopes = "write_themes,write_products,write_pixels,read_customer_events,read_checkouts"

[auth]
redirect_urls = [
  "https://tunnel-url.com/auth/callback",
  "https://tunnel-url.com/auth/shopify/callback",
  "https://tunnel-url.com/api/auth/callback"
]

[webhooks]
api_version = "2023-10"

[app_proxy]
url = "https://tunnel-url.com"
subpath = "***"
prefix = "apps"

[pos]
embedded = false

[build]
automatically_update_urls_on_dev = false
dev_store_url = "***"