Solved

Dear PHP expert, I'd like to ask which PHP version has to use for the orders API

postas
Shopify Partner
4 0 0

To whom may it concern

 

Hi ! I’m Jun Nakamura from Japan and work as a backend developer.

 

we have to update PHP version more than v7.3.0 if We would like to use Orders API ??
Because we are developing our application (Web service) by PHP which is v7.2.5
Furthermore using Shopify API which is [ graphql.json ], [ graphql.json ], [ graphql.json ]
I must apologize to ask you a lot of quesions.

If you know anything about useful info for above question, Could please you inform about that

 

Yours sincerely,

Jun Nakamura

Accepted Solution (1)

ShopifyDevSup
Shopify Staff
1357 224 473

This is an accepted solution.

Hi @postas - thanks for getting in touch! You could continue using your server's current version of PHP, however we would not be able to offer as much support as we do for folks using our PHP Library. You would have to build your app's API functionality directly if you continue to use 7.2.5. The official Shopify PHP API library does require PHP version 7.3+ as a dependency if you wanted to go that route. There is a bit more information on this here.

Hope this helps - please let me know if we can clarify anything further on our end. 

Developer Support @ Shopify
- Was this reply helpful? Click Like to let us know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

View solution in original post

Reply 1 (1)

ShopifyDevSup
Shopify Staff
1357 224 473

This is an accepted solution.

Hi @postas - thanks for getting in touch! You could continue using your server's current version of PHP, however we would not be able to offer as much support as we do for folks using our PHP Library. You would have to build your app's API functionality directly if you continue to use 7.2.5. The official Shopify PHP API library does require PHP version 7.3+ as a dependency if you wanted to go that route. There is a bit more information on this here.

Hope this helps - please let me know if we can clarify anything further on our end. 

Developer Support @ Shopify
- Was this reply helpful? Click Like to let us know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog