Deprecated API calls - Metafield.valueType

moshelog
Shopify Partner
19 0 5

We're getting Api call deprecation "`Metafield.valueType` has been removed. 

 

We use the latest "Event version" 2022-04, and our code (webhooks) has been updated accordingly. 

 

We're not sure where this deprecation call is coming from and will be happy to know where we can get more info about these calls.

 

Can we contact the Shopify developers team directly? is so, what is the email?

 

 

Thanks

Moshe Lugasi
Replies 16 (16)

Daniela-M
Shopify Partner
22 1 51

Hi there @moshelog,

 

Please check this resource and see if it helps: https://shopify.dev/apps/metafields/types#metafield-value_type-deprecation

 

Install Order Tracking Page & Returns app and NEVER receive ''Where is my order?'' support tickets.

Check WeSupply Labs for full features and get your FREE plan.





moshelog
Shopify Partner
19 0 5

Hey, @Daniela-M 

 

Thanks, but that's the first thing we did, but we still don't know where this deprecation call is coming from. we checked our code multiple times. 

 

 

Moshe Lugasi
SagarNagendra
Shopify Partner
7 0 3

Hi,

      Did you find any solution? Still, don't know where this deprecation call is coming from. updated all metafield api's 

Tejas_Sangoi
Shopify Partner
48 0 3

We are facing the same issue. Did you get a solution?

SagarNagendra
Shopify Partner
7 0 3

Hi tejas, I found the solution

 

Tejas_Sangoi
Shopify Partner
48 0 3

Thanks for replying. What is the solution?

Starlynne
Shopify Partner
8 0 6

We're having the same problem - did you find a solution? I have been through all of my code that relates in any way to the metafield API, and I cannot find this deprecated key. 

Aiden_Tran
Shopify Partner
1 0 0

Hi @SagarNagendra , I'm facing the same issue as you. Can you share your solution? Thank you very much.

ShopifyDevSup
Shopify Staff
1367 228 479

Hey @Starlynne - can you confirm if you've updated your app's API version to version 2022-04 or later? This issue seems similar to the one described here and the workaround suggested by my colleague there appears to have resolved similar issues for folks in the past. 

If neither of the two solutions offered in that post help, just send me a private message with your Partner Organization's and app's name and we can look into this further with you. 

Developer Support @ Shopify
- Was this reply helpful? Click Like to let us know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

Starlynne
Shopify Partner
8 0 6

Hello, 
Thanks for the suggestion! 
I was able to find one place in my code where we did not specify the version, and I have corrected that. 
I also updated my webhooks API version in case it was picking up that and the messaging was just off. 
The bad call was last detected at about 5 hours ago - before these changes. So I suppose I wait for tomorrow and see if it is found again? 

I did try to send you a PM but it said it was not enabled. 

Thanks!

Starlynne
Shopify Partner
8 0 6

@ShopifyDevSup 
It turns out the problem was the unspecified version call. 

We are now having serious issues as the Unsupported message and notifications are still being shown to our customers. We need to get that flag removed asap. 

Since the documentation says an unspecified call will default to the last supported version, it returning an unasked for deprecated value is really not expected behavior. That is causing the Unsupported flags without our app actually doing unsupported things - but we are still getting the fallout from having that flag on our app. 

Any help would be greatly appreciated! 

ShopifyDevSup
Shopify Staff
1367 228 479

Hi @Starlynne, Thats great that you located the issue. The banner is expected to stay visible for 14 days after the last call to the deprecated resource was made. You can determine when the last call was made using the API to check the status of deprecated calls as detailed here. https://shopify.dev/api/admin-rest/unstable/resources/deprecated-api-calls. Hope that helps. 

Developer Support @ Shopify
- Was this reply helpful? Click Like to let us know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

bchoward
Shopify Partner
5 0 8

Hi @ShopifyDevSup,

 

We also have this issue, the Unsupported app message and notifications are being shown to a lot of our customers. It is seriously impacting our app reputation, putting our company at stress.

 

For the record, we did the version upgrade to 2022-04 a few months ago when we first received this error below. The upgrade was simple because we use centralized library to make every Shopify API calls.  But still, this error keeps coming back, no matter how hard we double, triple checked our entire code base. We cannot call the deprecated-api-calls because our app is public, not custom app. We tried it but got Not Found error. So we can't track down where the error came from.

bchoward_0-1674761557207.png

 

Further more, in this specific situation, I think the label "Unsupported" is a very negative and misleading claim because our app is still functioning well. Just due to some single, random api call, (if any) that can simply mark an app as Unsupported, does not really make sense.

 

We are also working directly with Shopify Support team via this ticket 35864867.

 

Please help us to resolve this issue asap, we need to know which API call that caused it, the more detail the better. Thank you!

 

App name: Boost Product Filter & Search

Partner Organization: Boost Commerce

ShopifyDevSup
Shopify Staff
1367 228 479

Hey @bchoward,

Based on the info you shared, we suggest you continue to work with our Partner Support team through the ticket referenced, to ensure it is resolved as soon as possible. This team specifically handle requests from Shopify Partners that involve the Partner Dashboard, tools, notifications, as well as helping answer questions and sharing best practices, eg. API versioning, app distribution, etc. Additionally they can connect with more technical teams in the case of unexpected behaviors, or field any direct feedback you would like to share. 

We have also moved your second post to create a new thread over in the Partner Discussion forum board that is intended for community conversations around the Partner Program (partner dashboard, app requirements, platform support, etc). This API & SDK board is intended as a surface to connect with the community for technical API and development related questions, that include topics around the functionality of our various APIs and SDKs. 

That said, we will keep this thread open to allow for further discussions on the initial topic - Best!

Developer Support @ Shopify
- Was this reply helpful? Click Like to let us know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

Amit_Porwal
Shopify Expert
51 0 5

I agree. A label like Unsupported, outdated is vert very negative and its impacting our app too, people are removing app immediately. Churn increased and we dont know from where this is coming. Apps team, we request you to please ensure that such labels are not added in front of merchants and first intimation should be sent to us as we will fix it, we always do.
If we dont do it, you can deactivate the app as thats a correct solution but labelling an app negatively impact a lot on our app's credibility. 
😞
If anyone find solution please let us know.

ItsMeBuddy
Shopify Partner
12 1 1

Hi @ShopifyDevSup,

We too have the same issue with both our apps named DATA EXPORT and REPORT PUNDIT. We have checked our entire code base and we can assure you that we were not making any depreciated APIs calls. But still we were getting the same warning message. And the current API version that we use in our app is "2022-07".

We tested by removing the API version from the URL and made one API call. According to the Shopify docs, if the API version is not specified in the URL then it would switch to the latest API version. And even after using this method it still show the same warning. We were not able to figure out where the exact issue is. We believe its something with the meta fields endpoint.

Please let us know if we are missing something. Customers seeing the “unsupported app” message in the app even after switching to latest API version is frustrating.

 

Thanks!