Permissions error after read_all_orders approval

Luke-FA
Shopify Partner
1 0 0

Hello Shopify community, 

 

We just received approval for our public app to use the 'read_all_orders' permission. Upon adding it to the access scope during the Oauth process, it is throwing an error that doesn't seem to make sense. 

 

Our original access scope string was: 'read_orders,read_customers,read_discounts,read_draft_orders,read_gift_cards,read_products,read_shipping,read_fulfillments'. This was reflected in the permissions grant screen correctly and worked as expected. 

 

The new access scope upon approval is: 'read_all_orders,read_orders,read_customers,read_discounts,read_draft_orders,read_gift_cards,read_products,read_shipping,read_fulfillments' This throws an error during the Oauth that states 'Oauth error missing_shopify_permission: read_customers'. Clearly the 'read_customers' scope is in the string.

 

Also, testing with an access scope of 'read_all_orders,read_orders,read_customers' throws the same error about the 'read_customers' scope missing. Am I missing something with this 'read_all_orders' access scope? 

 

image (11) (1).png

Replies 0 (0)