Credentials wrong when i try to do a GET API Call

Credentials wrong when i try to do a GET API Call

kukustyle
Shopify Partner
1 0 0

Hello everyone, i'm building a new store and trying to sync store with an external source, i also created a Private App on the store and give all permission write/read to the App. The issue is that when i try to do a test GET request ( for example for get detail of a product ) from the browser where i'm logged in on shopify the GET request work, but if i try with Postman, from my php app, or simply from another browser shopify ask me credentials.

I also checked many times the API credentials and password and are correct but i still get same error.

 

The GET url that i'm trying is:

 

https://https://APIUSER:APISECRET@myawesomestore.myshopify.com/admin/api/2021-10/products/7693108805858.json

 

APIUSER and APISECRET are the credentials on the attached screen.

What's wrong? 

 

Why? What's wrong?

Screenshot 2022-04-21 at 18.17.19.png

 

Reply 1 (1)

lizk
Shopify Staff
246 58 74

Hi there!

I would recommend reviewing this documentation about using Access Tokens for Admin Custom Apps, these have replaced Private Apps.
https://shopify.dev/apps/auth/admin-app-access-tokens

They will be using the X-Shopify-Access-Token header, instead of the user password method.

Your access token will be revealed to you once when you create and install your custom app.

To learn more visit the Shopify Help Center or the Community Blog.