Production index.jsx/dev_embed.js failed to load.

artis-overly
Shopify Partner
1 0 0

Hi!

It looks like I`m missing something for deploying app to production.
I have developed app/extension on Laravel + ReactJS.
Tested it thru ngrok.io - everything was smooth and everything was working fine.
Now I have set up app on production server.
Updated the URLs in app settings. So Authorizations is going thru. (so server side is working fine)

But when my apps is loaded I receive  these errors:
ERROR-1.jpg For production I run: 

npm run shopify app build

Everything is going thru, no errors and I got status, that app is built successful.
But these files don't exist on server /root directory, where index.html and assets shortcuts are generated, after the command is executed.

An why there still are some ngrok connection when loading app thru production server?
Am I missing something? Do I need to do some extra steps? Or do some extra configuration for production?

Don't even know how to describe this correctly... 

 

P.S.
After these strange errors when I run 

shopify app dev

on local computer and app is running thru ngrok.io - of course, there are no these kind of errors.

 


Thank You.
Hope some one can help me about this issue.
Artis.

Reply 1 (1)

TamasL
Shopify Partner
1 0 0

Hi,

 

The .env file needs to contain:

APP_ENV=production