Storefront API not returning products. "Internal Error. Looks like something went wrong on our end"

10 0 3

I have a custom front-end that queries for products uploaded onto Shopify through the Storefront API. Everything was working fine previously where I was able to query through the API for the products, get next page products etc. 


But just earlier (like maybe an hour plus ago), the query through the Storefront API is returning me only 7 or 8 results.


I have made no changes to my front-end code or any of the products' availability on my Shopify store. What could have gone wrong?

Screenshot 2020-04-07 at 12.25.34 PM.png


I received this error during one of the many API calls while trying to find out what went wrong.

Would really appreciate some help as the page is live right now!

Many thanks,



The stop gap measure I have is to update the Product Availability to be not available on a channel, save it and then make it available again and save it. This is definitely not a sustainable solution. Will any Shopify expert or support team be able to look into this?

Replies 2 (2)

Shopify Staff (Retired)
624 104 187

HI @eugeneoei ,


Taking a look through our platform logs for the X-Request-ID you provided, it appears that this error happened due to an authorization check. So I would just make sure that your app using the Storefront API has the correct access scopes and is using the right access token to hit this API and get this information.


I have also tested your GraphQL query for your store, and was able to verify that everything worked with no issues. I was able to get all 60 products returned. So its possible whatever issue you were getting previously is not longer the case. 


To learn more visit the Shopify Help Center or the Community Blog.

10 0 3

Hi @hassain ,


Thanks for replying to my post!

On the previous occasion, that error occurred only once. I had no errors subsequently.

Unfortunately, just two days ago, a similar situation happened again. When a query was made for "products"  using the "query" filter parameters "tag", the GraphQL query failed to return any results. Specifically, the "tag" queried for is "100% Linen". Without changing any of my code, the "problem" was solved by toggling the product's availability.


It's definitely a very weird occurrence and I am praying so hard this does not happen again since we will definitely be introducing more products down the road. Otherwise, to toggle the product's availability one at a time is going to take up so much time. Plus, the mass editing/toggling of product's availability does not seem to solve the "problem". Only when it is done on an individual product level will the "problem" be solved. Then again, I wouldn't call this toggling method a "solution" either.

So, this "problem" I have still kinda persits.


Eugene Oei