Solved

How to stop creation or language country combos in URL

valleplateado
Tourist
6 0 1

I am selling in multiple markets but only in two languages (en and es). For some reason, for different language + country combos, there is a new url being created, such as "en-mx" for Mexican users in English.

How can I avoid this so its just based on language? Or is this not possible? 

valleplateado_1-1679169021388.png

 

Accepted Solution (1)

coleatkinson
Shopify Staff
141 13 76

This is an accepted solution.

You can control the URL that is being used for each market in Settings --> Markets.

 

Here, it seems you have a Mexico market that is using the subdirectory en-mx. If you don't want this to happen, you can navigate to the Mexico market in settings, then go to Domains and languages, and select Primary domain only. This way your market will use the same domain as your primary.

Cole | Product @Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

View solution in original post

Reply 1 (1)

coleatkinson
Shopify Staff
141 13 76

This is an accepted solution.

You can control the URL that is being used for each market in Settings --> Markets.

 

Here, it seems you have a Mexico market that is using the subdirectory en-mx. If you don't want this to happen, you can navigate to the Mexico market in settings, then go to Domains and languages, and select Primary domain only. This way your market will use the same domain as your primary.

Cole | Product @Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog