Translate & Adapt App - Not following markets settings

Translate & Adapt App - Not following markets settings

fyt
Excursionist
26 1 5

Hello, 

 

I have installed Translate & Adapt App. 

I set on the German market only the default language as German. 

 

In other countries markets I set default language as English. 

 

But people from everywhere are getting German as default language. 

How can I set it properly? Is it necessary to use a geolocation app?

 

url is: https://fytwine.com/

 

Thanks

Replies 10 (10)

richbrown_staff
Shopify Staff
651 95 160

Hi @fyt , looking at your Markets just now you have 'Primary domain only' as the domain and subfolders settings on your secondary markets. Which means they follow how your primary market, Germany, is setup - which has German as the default language. To change, we'd recommend switching to subfolders, with English as the default language in secondary markets. People browsing in languages other than German can then land on the English experience in two ways: 1) Hreflangs begin to index on search engines. If I'm in the UK and browse in English, and search fytwine, very soon it'll be defaulting to the correct experience. 2) As you mention, you use the Geolocation app. If I land on the wrong country / language, a pop up takes me to the right one.

To learn more visit the Shopify Help Center or the Community Blog.

fyt
Excursionist
26 1 5

Hey @richbrown_staff ,

Thanks for the answer. 

Yes I had it on subfolders before. 

 

I see what you mean, question is if you're are in UK you should switch the language by yourself to start the process of indexing and defaulting, or it will automatically be done with time?

 

For the second option I now have as primary domain with the geolocation app from shopify installed. But it doesn't always work. Do you know why?

richbrown_staff
Shopify Staff
651 95 160

No problem. It will index over time, nothing you need to do. What's not working with the Geolocation app? I can pull in the relevant team.

To learn more visit the Shopify Help Center or the Community Blog.

fyt
Excursionist
26 1 5

The geolocation app just doesn't show up. 

richbrown_staff
Shopify Staff
651 95 160

The Geolocation app should show up when it's needed - i.e. when you land in the wrong place. If you're testing on your own computer it won't show if you're in Germany, browsing in German, as that is your primary market / language. Try using a VPN and changing your location to a country in one of your other markets, and / or set your browser language to English, and see if shows. If it doesn't work please let us know.

To learn more visit the Shopify Help Center or the Community Blog.

fyt
Excursionist
26 1 5

Ok, I see. I think also the problem was that markets weren't set on sub folders. So even if the geolocation app was showing app the language was still German. Now I set the subfolders, and it should work. 

fyt
Excursionist
26 1 5

Ok, the app looks like is working, but when I select country and language it lands on a 404 page. Where can I redirect the page from?

fyt
Excursionist
26 1 5

@richbrown_staff ok I think I need to make markets for each single country if I use this way right? 

I have now groups, that's why is probably redirecting to a 404 page. Could be right?

richbrown_staff
Shopify Staff
651 95 160

Hi @fyt - you wouldn't each country to be its own market, no. It should work as you have it setup. Where are you seeing the 404 - following sitelinks in Google? If so it'll be because your old market setup is still indexed.

To learn more visit the Shopify Help Center or the Community Blog.

fyt
Excursionist
26 1 5

No the 404 was showing up in my website after clicking continue on the geolocation pop up with vpn. But now it works with markets for each country.