Metafield placeholder content is #{" "} ?

Solved

Metafield placeholder content is #{" "} ?

simonbarker
Shopify Partner
8 0 8

Looks like there's a bug in metafields - the placeholder for a blank metafield is #{" "} ? This seems new since 12th Jan?

 

Anyone else seeing this?

simonbarker_0-1705307654066.png

 

Accepted Solution (1)
Liam
Shopify Staff
2873 312 821

This is an accepted solution.

Update on this - our team was already aware of this issue and have just shipped a fix for this. It should populated across to your store later today.

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

View solution in original post

Replies 5 (5)

Liam
Shopify Staff
2873 312 821

Hi Simon,

 

I'm not seeing this for empty metafields on products on my test store, eg:

 

Can you give any more details on this issue? eg: when it started, is it affecting all store resources or only some, have you installed any apps recently that could be editing metafield values?

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

simonbarker
Shopify Partner
8 0 8

Hi Liam,

 

I first noticed it this morning on our dev store, then checked production and spotted it there.

 

It seems to be for all orders and it wasn't there on Friday. It's only for metafields that don't have a value in them. When I do an API request to the metafields endpoint for an order I get only metafields that have a value, it seems to be just the on screen placeholder? Using chrome dev tools element inspector it seems to be the contents of the after s.l.o.t (read without dots in, the naughty word filter didn't like it spelled without dots even thought that's a valid name for part of a web component) in the component. These are order metafields with definitions as well if that matters.

 

No apps installed recently and I have confirmed with the wider team that I'm not the only one seeing this.

Liam
Shopify Staff
2873 312 821

I've connected with our team on this strange issue - feel free to DM me the store too which would make it easier to troubleshoot this issue.

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

Liam
Shopify Staff
2873 312 821

This is an accepted solution.

Update on this - our team was already aware of this issue and have just shipped a fix for this. It should populated across to your store later today.

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

simonbarker
Shopify Partner
8 0 8

Thanks, yes looks like this is now fixed.