Solved

Newly Added Metaobject Entry Not Shown in Online Store Frontend

arieswen415
Shopify Partner
20 5 3

Problem Description

I use Metafields [metaobject_reference] to display product specifications on my online store. However, when I added some new products and their spec entries today (10/11/2023), the spec content did not show up on the website (the old products are fine). I was wondering why this is happening and if anyone is facing the same problem. Is there any update from Shopify end or I reach the limit of Metaobject entries? What should I do here to fix this issue?

 

Some Attempts

  1. I tried to add old entries to the newly added products. The content shows up with no problem. Only the newly added entries do not show up (on the same product page), so I assume my theme codes have no problem.
  2. I tried adding the entries both manually and using GraphQL API. Both did not work.
  3. I tried to `console.log` the data. It prints nothing for newly added entries and prints correct data for old entries

 

Other Info

  1. The entries and products are properly linked. I can seen the entry on product admin page, and I can access the entry through GraphiQL App.
  2. All Metafields [metaobject_reference] have the same problem. Any entry content I added today does not show up on the online store.

 

I tried to find out what was causing the issue, but I only found out that the new entries added today did not work anymore. The entries that I added two days ago worked just fine. If anyone could let me know what happened here, that would be great.

 

Any input is appreciated! Thank you for taking time reading this message.

Accepted Solution (1)
arieswen415
Shopify Partner
20 5 3

This is an accepted solution.

Hi Liam,

 

Thank you for your reply.

 

IT IS an unusual issue. However, the bug was fixed  by itself when I check the products the next day, so I can't provide any more details about the issue. Till today, I still don't know what happened at the time.

 

I still want to take a moment to thank you for replying this post. Hopefully the same issue won't come up again.

View solution in original post

Replies 2 (2)

Liam
Shopify Staff
2731 302 777

Hi Arieswen415,

 

This does indeed seem like an unusual issue. Just to confirm, you have a metaobject set up with some entries that have been created at different times. For this metaobject some of the entries are appearing on product pages but no entries created after 10/11/2023 are appearing - is this correct? 

 

How many entries in total do you have? Did you recently install any apps that would affect the storefront or metaobjects? If you can share your store either here or via DM that would help too. 

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

arieswen415
Shopify Partner
20 5 3

This is an accepted solution.

Hi Liam,

 

Thank you for your reply.

 

IT IS an unusual issue. However, the bug was fixed  by itself when I check the products the next day, so I can't provide any more details about the issue. Till today, I still don't know what happened at the time.

 

I still want to take a moment to thank you for replying this post. Hopefully the same issue won't come up again.