Return management just got easier! We’ve launched Customer Self-Serve Returns to all Shopify merchants. Click here to learn more!

Internal server error http://127.0.0.1:9292/

aahd
New Member
2 0 0

Hi, I have 2 stores in development and would like to have them both in local but when I ran theme serve for the second, I got an error 127.0.0.1:9292 is already in use so I did

$ shopify theme serve --port=PORT

but now no port works, either http://127.0.0.1:9292/ or http://127.0.0.1:0/

And I have this message on the page for http://127.0.0.1:9292/

Internal Server Error

No such file or directory @ rb_sysopen - /usr/local/Cellar/shopify-cli/2.10.2/gems/shopify-cli-2.10.2/lib/shopify_cli/theme/dev_server/hot-reload.js


WEBrick/1.7.0 (Ruby/3.0.3/2021-11-24) at 127.0.0.1:9292

 

I'm not sure what to do, any ideas? Thanks!

Replies 4 (4)
mcclardhabitat
New Member
2 0 0

I am having the same error occur every time I save a file. If I refresh the browser a couple of times it ends up loading, but it's pretty frustrating.

aahd
New Member
2 0 0

I refreshed it a lot of times but it's not working, my temporary solution is to put it on the 9293 port but I would like to fix it.

I uninstalled shopify-cli and installed again but I still have this message.

I have shopify-cli-2.11.2 so I don't get why it's looking in a folder 2.10.2 that doesn't exist anymore.

raultoks-peppy
Shopify Partner
5 0 2

Try seeing what process is using your tcp port, kill it and run the app again should work.

 

cfx
Shopify Partner
26 2 8

I ran into this same issue and was able to solve it (on Mac) by doing this:

$ sudo lsof -i :9292

 

I saw a bunch of ruby threads running on port 9292. There was also a Google process, but I just focused on the ruby thread PID and I then did this:

$ kill -9 <PID>

 

After that, I ran CLI again and it was smooth sailing. HTH!