Metafields not showing as an option when aiming to insert Dynamic Sources

8 0 3


Hi everyone -


I'm trying to put size charts on the product pages under a collapsible tab. The steps that I followed are:


- Create a Metafield with content type File

- Add for each product the image of the size chart on that metafield

- When I go to Customize the Product Page, I select collapsible tab, and when I click on insert dynamic source the metafield that I created doesn't appear


I'm using Dawn. Any advise on why the metafields are not showing?


Many thanks in advance,



Replies 6 (6)
130 0 40

Did you ever get a solution to this?  I'm trying to change to the Craft theme which works the same way and I'm having the SAME problem!  So far Shopify support is silent and Google searches are coming up empty.  😞

3 0 0

Same here. I created a list of product metafields already. But when i tried to insert dynamic source, there is an "Add Metafield" link. I clicked on the "Add Metafield" link, it brings me to the Product Metafields list but there's no way to add additional product metafields. 

130 0 40

I finally figured it out for mine, see if it works for you.  I discovered that when you go to choose the metafield, there are two places you can add dynamic sources from.  When I clicked the first one, it did not show the metafields that I'd created.  Clicked on the second one and they were there!


I've attached a small screenshot.  Try clicking the dynamic source from the lower one that's labelled "Row content from page" and not the one that says "row content". 


I don't know what's the difference between the two, and it's not documented that I could find!  But one works and one doesn't.

Screen Shot 2022-08-09 at 12.43.29 PM.png

13 0 6

I'm having the same exact same issue on Dawn, this didn't work for me! 

New Member
1 0 0

I've just tried this and it doesn't show anything for me on the "row content from page" and the one metafield I do want is missing from the list on "row content."  Frustrated not to find a solution for this.

New Member
3 0 0

Okay this solution is kind of bonkers, but it worked for me so I thought I'd reply here for other people searching for an answer. I came across this reply where designsbymcn outlined how they set up their metafields under their collapsible rows, and I decided to follow it to the letter, including creating new collapsible rows.


On the new collapsibles I'd just added, the metafields were there just like they ought to be, they linked up correctly to the content I wanted, and in general just worked exactly as they were supposed to. I don't know what's wrong with the original fields that are included with the theme (I'm on Craft and I think it's basically the same setup as Dawn), but apparently they're defective. 😫 


With the new collapsibles I'm still not able to use some types of metafields, like the Measurements one simply wouldn't appear no matter what I did, but it's ended up being quicker to enter when it's just a text field anyway. Tagging @Sharon15 @iriswee @Aeterius and @mkarim in case you're still looking for a solution, maybe give this a try.