No templates found

Solved
davros
New Member
2 0 3

Any idea why I'm seeing this? I have a fresh install of Dawn, no apps installed. I'd like to edit a template or create a new template in the theme editor but I only see the message "No templates found for products" (or Collections). Doesn't make a difference whether the theme is published or not.

Troubleshooting tips appreciated.

 

Screenshot 2021-11-02 at 16.51.34.png

Accepted Solution (1)

Accepted Solutions
roband
Tourist
7 1 9

This is an accepted solution.

I just got an email from Shopify support telling me the bug is fixed.

I can confirm that uploading a new OS 2.0 theme now works as expected, the template selector is functional again.

Themes uploaded while the bug was active are still bugged, so I just deleted them and uploaded again.

View solution in original post

Replies 8 (8)
roband
Tourist
7 1 9

I have the same problem, for all OS 2.0 themes. Was something broken in the Shopify theme editor recently?

Ardi94
Pathfinder
101 2 26

My previous versions of Dawn are working properly but the new version doesn't show any template in the theme customization. But the templates are there in the codes. I even tried creating a new template in code editor to see if it shows up but no.

Jkatz23
Tourist
10 0 6

i m having same issue... i thought it was a error i made in the code because other themes i am able to see the templates... but the newly created ones i am not...

roband
Tourist
7 1 9

I have reported the bug to Shopify support. They confirmed the bug and have passed it on to the developers. We'll see what happens...

roband
Tourist
7 1 9

This is an accepted solution.

I just got an email from Shopify support telling me the bug is fixed.

I can confirm that uploading a new OS 2.0 theme now works as expected, the template selector is functional again.

Themes uploaded while the bug was active are still bugged, so I just deleted them and uploaded again.

View solution in original post

Jkatz23
Tourist
10 0 6

How do we rectify the issue if the current live them has the bug? Any duplicate of that theme would still have it right?

Ardi94
Pathfinder
101 2 26

Yes, I just tried it. If you duplicate your theme, the issue is still there. You have to redownload your theme. (Unless there's a way that I don't know about)

Jkatz23
Tourist
10 0 6

i duplicated the live theme which had the issue and the newly generated theme did not have the issue anymore. So it worked over here, something weird has definitely been up recently with theme issues.