Shopify command not working

Solved
MarkoRakic
Tourist
5 0 10

I have installed shopify-cli gem. I opened a new terminal and tried to check if it is installed successfully.
But I am getting this error.

Traceback (most recent call last):
4: from /Users/admin/.rvm/gems/ruby-2.7.0/bin/ruby_executable_hooks:24:in `<main>'
3: from /Users/admin/.rvm/gems/ruby-2.7.0/bin/ruby_executable_hooks:24:in `eval'
2: from /Users/admin/.rvm/gems/ruby-2.7.0/bin/shopify:23:in `<main>'
1: from /Users/admin/.rvm/rubies/ruby-2.7.0/lib/ruby/site_ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
/Users/admin/.rvm/rubies/ruby-2.7.0/lib/ruby/site_ruby/2.7.0/rubygems.rb:278:in `find_spec_for_exe': can't find gem shopify_api (>= 0.a) with executable shopify (Gem::GemNotFoundException)


These are my gem list

shopify-cli (2.5.0)
shopify_api (9.4.1)
shopify_app (18.0.2)


I tried to run bundle update --system but it was not helpful.

How can I fix the issue?

yudechen
New Member
2 1 8

This is an accepted solution.

@MarkoRakic, are you using RVM?

If yes, can you try running rvm reset and check again?