Assets API

EdgarsL
Shopify Partner
1 0 4

Hello!

When exactly can we expect that the 2023-01 version of Admin API to no longer be functional? We've heard that the Asset API v2023-01 Scope change deadline has been extended to April 2024, but testing Assets API calls with version 2023-04 returns 404 Not Found response.

Thanks in advance!

Replies 6 (6)

Shaibt
Shopify Partner
34 1 30

Shopify just sent a delisting warning ("Update your Shopify apps before January 2, 2024") because our app uses API ver 2023-01  to modify theme assets. The API health console is showing this message:

 

Starting on April 1, apps must request approval from Shopify for create/update or delete access to Asset API version 2023-04 or later. You should transition your app to the recommended alternative, Theme App Extensions, by December 31. To avoid disruption to how your app works, use Asset API version 2023-01 until you implement Theme App Extensions.

If the deadline is extended to April 1st, why is Jan 2nd a deadline? Something is not aligned internally in Shopify here.

elijahcohen
Shopify Partner
2 0 0

Experiencing the same thing with our app -- @Shopify please clarify!

elijahcohen
Shopify Partner
2 0 0

@Liam Could you help us understand the delisting warning given the extended deadline to transition away from the asset API version 2023-01?

Liam
Shopify Staff
2731 292 743

Hi folks,

 

Apps can continue to use the API version 2023-01 until March 31st, and won't be delisted from the Shopify App Store. Apps which have not updated yet are seeing the warning in the dashboard because a grace period flag has been added to public apps that are not updated yet to allow them to continue making calls to the outdated version - we'd recommend that you update as soon as possible.

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

ihsfr
Shopify Partner
6 0 1

We already updated to 2023-01 and are now getting the fix overdue message, and also getting this banner on our app store install pageScreenshot 2024-01-04 at 10.33.10 AM.png

Liam
Shopify Staff
2731 292 743

Hi Ihsfr,

 

You should be making calls to 2023-04 or higher to avoid seeing this banner as 2023-01 is techically an unsupported version, even though we've added a manual grace period flag to public apps still making outdated calls. 

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog