Metafields aren't showing up after bulk editing.

AnhVNguyen
Visitor
3 0 0

Hi everyone

I'm running into an issue where metafields content is not showing up after bulk editing. would be much appreciate to get some advice on show to fix this. 

 

So I have followed the bulk adding Metafields in this article and it works fine. 

https://community.shopify.com/c/shopify-apps/ultimate-guide-on-using-metafield-in-shopify-for-busine...

AnhVNguyen_1-1648335825772.png

 

However, when check each product setting, the metafields are all blank. I have gone back to check in the bulk editor but everything looks fine. What have i done wrong? or if i have missed out any steps to make it work?

AnhVNguyen_2-1648335887108.png

 

 

 

Replies 4 (4)

MetafieldsGuru
Shopify Partner
158 32 99

Hi @AnhVNguyen ,

 

Indeed, that's quite a weird problem. You may want to make sure that the data wasn't deleted during the bulk update (or after). You can do that with an API request or by installing a metafields app.

Check out Metafields Guru, the #1 ranked metafields app.

Bulk editor | Data import/export | Metafield sets | Browser extension
AnhVNguyen
Visitor
3 0 0

I can see the data is still there in the bulk editor 

Jonathan-HA
Shopify Partner
320 24 99

I just did a quick test on our test store and seeing the same behavior.  The field is showing up in the bulk editor when modifying the URL, but after making the changes and hitting "Save", the data didn't save.

 

Editing the Metafields via the individual resource pages still works though.

 

Could it be related to this post? https://community.shopify.com/c/discussions/bulk-editing-feature-for-some-metafields-is-being-turned...

Co-Founder / Developer at Highview Apps
Our Shopify Apps: EZ Exporter | EZ Inventory | EZ Importer | EZ Notify | EZ Fulfill
AnhVNguyen
Visitor
3 0 0

Thanks for the reply Jon, i made the changes in the bulk editor before the 4th April so i'm not sure.