Metafields not showing as an option when aiming to insert Dynamic Sources

OriolBS
Tourist
8 0 5

 

Hi everyone -

 

I'm trying to put size charts on the product pages under a collapsible tab. The steps that I followed are:

 

- Create a Metafield with content type File

- Add for each product the image of the size chart on that metafield

- When I go to Customize the Product Page, I select collapsible tab, and when I click on insert dynamic source the metafield that I created doesn't appear

 

I'm using Dawn. Any advise on why the metafields are not showing?

 

Many thanks in advance,

 

Oriol

Replies 12 (12)

Sharon15
Pathfinder
138 0 49

Did you ever get a solution to this?  I'm trying to change to the Craft theme which works the same way and I'm having the SAME problem!  So far Shopify support is silent and Google searches are coming up empty.  😞

iriswee
Tourist
4 0 0

Same here. I created a list of product metafields already. But when i tried to insert dynamic source, there is an "Add Metafield" link. I clicked on the "Add Metafield" link, it brings me to the Product Metafields list but there's no way to add additional product metafields. 

Sharon15
Pathfinder
138 0 49

I finally figured it out for mine, see if it works for you.  I discovered that when you go to choose the metafield, there are two places you can add dynamic sources from.  When I clicked the first one, it did not show the metafields that I'd created.  Clicked on the second one and they were there!

 

I've attached a small screenshot.  Try clicking the dynamic source from the lower one that's labelled "Row content from page" and not the one that says "row content". 

 

I don't know what's the difference between the two, and it's not documented that I could find!  But one works and one doesn't.

Screen Shot 2022-08-09 at 12.43.29 PM.png

Julia777
Excursionist
15 0 9

I'm having the same exact same issue on Dawn, this didn't work for me! 

mkarim
Tourist
3 0 1

I've just tried this and it doesn't show anything for me on the "row content from page" and the one metafield I do want is missing from the list on "row content."  Frustrated not to find a solution for this.

la-leg
Visitor
1 0 1

I hope you came across some solution. Here's one method: https://youtu.be/VFAxr_v-8n4?si=BpYG0JkJewbcRaYO

 

Procedure is like: (1) Create a size chart metafield that takes a page as its value*, (2) create a page (or several) with a size chart -- can be an image or a table, (3) select the size chart metafield value (your size chart page or pages) for the desired products, (4) in theme editor, edit the default product to have a drop-down or pop-up (if the chart is wide, a pop-up is better), (5) select a size chart page as the content for the pop-up, (6) after selecting a page, an option will appear for "choose dynamic source". Click on that, pick your size chart metafield, then the value of the metafield (which is one of your size chart pages).

 

* Important nuance is that when you're adding your size chart metafield, the metafield and cannot be a list of values. It has to be the default one value.

StrangeSpecies
Tourist
6 0 2

Okay this solution is kind of bonkers, but it worked for me so I thought I'd reply here for other people searching for an answer. I came across this reply where designsbymcn outlined how they set up their metafields under their collapsible rows, and I decided to follow it to the letter, including creating new collapsible rows.

 

On the new collapsibles I'd just added, the metafields were there just like they ought to be, they linked up correctly to the content I wanted, and in general just worked exactly as they were supposed to. I don't know what's wrong with the original fields that are included with the theme (I'm on Craft and I think it's basically the same setup as Dawn), but apparently they're defective. 😫 

 

With the new collapsibles I'm still not able to use some types of metafields, like the Measurements one simply wouldn't appear no matter what I did, but it's ended up being quicker to enter when it's just a text field anyway. Tagging @Sharon15 @iriswee @Julia777 and @mkarim in case you're still looking for a solution, maybe give this a try.

Linfei
Shopify Partner
1 0 1

I just got the same problem and luckily found the answer 😊

 

Single line Inputs(Liquid code: [type: text]) can only be attached to [Single line text metafield]. Like below:

Linfei_0-1681199133480.png

 

If I want to attach [multi-line text], I need to make this Input be multi-line Input [d.h. type: richtext], otherwise i should modify the metafield to single line text.

Linfei_1-1681199329055.png

 

Hope it can help to solve out 🙂

Strive to develop good looking website 🙂
Lipi1
Visitor
1 0 0

I created a page of size chart. Then added that page from row content. It worked.

Coconauts
Visitor
1 0 1

This works only if the Size Guide is same for all the products.

It will not dynamically change for a give product. The whole purpose of Metafields is to fetch per-product/page dynamic data.

Twelvetia
Tourist
7 1 1

What is the status of this problem? We are still facing it and the solution with individual pages for each product is completely pointless.

mateco
Visitor
1 0 0

I have had the same problem and was able to fix this - when you go to link the dynamic content there is a tiny drop down menu with options "raw content from page" or "product". Mine was changed to "raw content from page" and was not linking the metafield content, but when I changed it to "product" it worked!

 

mateco_0-1713804624255.png