Shopify CLI - Error: cannot load such file --wdm

falconert
Tourist
8 2 1
I am getting this error when running the command shopify theme dev with Shopify CLI:

 

[Note] You cannot use gems with Shopify CLI.
[LoadError] cannot load such file -- wdm
       They are disabled.
       Please don't modify the CLI locally.
       If you would like to contribute to the CLI project, please refer to
       https://github.com/Shopify/shopify-cli/blob/main/.github/CONTRIBUTING.md

  Please add the following to your Gemfile to avoid polling for changes:
    gem 'wdm', '>= 0.1.0' if Gem.win_platform?

 

Others who have had similar issues in the past suggested running gem install wdm, I have done this and had no success. Any help is appreciated.

  • Operating System: Windows 11
  • Shopify-CLI: 3.23.0
  • Ruby: ruby 3.0.4p208(2022-04-12 revision 3fa771dded) [x64-mingw32]
  • Node.js: v18.12.1
  • Bundler version 2.3.25 (2022-11-02 commit 6b0b87b1ed)
  • git version 2.38.1.windows.1

 

Screenshot 2022-11-14 141529.png

Replies 8 (8)

ShopifyDevSup
Shopify Staff
1422 233 488

Hey @falconert - thanks for bringing this up to us. Could you report this as an issue through the CLI's GitHub repo here as well? This is likely the best place to get developer eyes on this. I'd definitely include your mention of trying to install WDM and it not working when you create the issue through GitHub. I'll also take a look into this on my end - I can't guarantee a response through the forums, but I will follow up with you if I am able to discover anything. 

Hope this helps! 

Developer Support @ Shopify
- Was this reply helpful? Click Like to let us know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

BeWater
Shopify Partner
22 0 4

I have this same exact error. Is there a fix? I keep running into this error. It vanishes for 2 days then comes back... Help.

sinzen1
Shopify Partner
7 0 4

Hi, Please uinstall first shopify cli 2.x.x and reinstall the 3.x version.

BeWater
Shopify Partner
22 0 4

Can I just update Shopify CLI, or must I uninstall? 

sinzen1
Shopify Partner
7 0 4

It isn't really an issue, Simply make sure you don't have a version in ruby installed as the same.
Run :

 

shopify version

 

It should return correctly: 

 

Current Shopify CLI version: 3.25.0

 

 

 

 

 

 

sinzen1
Shopify Partner
7 0 4

as follows the post and answer the question. It isn't an issue really. Just ruby run with Shopify/CLI version 2. x has not upgraded yet. With Nodejs we don't need those packages just stay with the last version of Shopify/CLI as usual : 3. X  

BeWater
Shopify Partner
22 0 4

So I do not need Ruby at all? I am confused. 

sinzen1
Shopify Partner
7 0 4

Yes, you need ruby + devkit last version. but nodejs packages of shopify/cli 3. x run independently.

 

***

 

As like I said. This is not a blocking error **the topic of the post**. You can go forward step by step anyway of that error. First, you have to compile the PHP project everywhere. Then build the PHP project without error.. and run it