Theme App Extension not showing up on Dev Store

Theme App Extension not showing up on Dev Store

lovemadrid
Shopify Partner
2 0 3

Hello,
I'm an experienced react dev, but very new to Shopify.
I'm trying to create an app that displays a popup on storefront navbar, using Remix + app extensions.

I've created the extension using:

 

npm run shopify app generate extension

then choosing a "App Extension" type.

 1. Tried to turn on the App extensions from the Shopify partners dashboard.

Screenshot 2023-09-18 at 21.56.26.png

 

Was searching the internet and even tried some ChatGPT but nothing helps. 
The app itself appears in the shopify admin but when I try to edit my Theme (Default Dawn 2.0)  the app block doesn't appear!

The app block I have on my application is the default pre-generated app block - start_rating.liquid 

It's been a couple of days i'm trying with no success.

 

Maybe the TechStack I chose is not the correct one for my use case?

 

Thank you !

 

Replies 4 (4)

Liam
Shopify Staff
2862 313 816

Hi Lovemadrid,

 

Can you DM me with the store ID and your partner ID so we can look into this a bit further?

 

Thanks, 

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

mohitks
Shopify Partner
3 0 0

Hi @Kliam were you able to resolve this for op ? I am having exact same issue, I am using boilerplate app and boilerplate theme extension. No customisation whatsoever. Except the store I am using have preview enabled.

```

Preview your theme app extension:
12:39:53 │ extensions │ http://127.0.0.1:9292

```

Edit: it worked. We have to wait for above message before installing the app on store + had to remove the metadata settings (as it was probably not configured properly, docs don't make it clear enough). Note that above message will come after app has been published message. Theme is published later

rdomadia
Shopify Partner
1 0 0

I am facing same issue. Theme App Extension Not Showing

rdomadia_0-1706257353073.png

 

durdenx
Shopify Partner
3 0 0

Is there a solution?